Jump to content
Sign in to follow this  
UllyB

"Afterburner.ini"s missing ?

Recommended Posts

I extracted everything that can be extracted (except cockpit and models) but I can't see the Effects folder afterburners "ini"s and their effect TGA files. Where are they ? Are they locked ?

Also I tried to use a afterburner.ini file, I used in SF1 (plus its TGA effect file). I put them both in the EFFECTS folder made in mod main folder and they won't work. Any idea why ? That was the reason I was seraching for the "afterburner.ini"s in CATs, I want them to compare with the ones made in SF1 to see why they won't work.

Edited by UllyB

Share this post


Link to post
Share on other sites

my bad....its in flightdata.cat at top....afterburnerfire.tga

Edited by russouk2004

Share this post


Link to post
Share on other sites

I looked into those CATs, there is the afterburner TGA for the effect but I was talking about TGA files for the effect declared in the afterburner.ini alright ? The "afterburner.ini"s are not there, even if they are declared  in the plane's dataini file (in the engine section), so they must be somewhere. From what I know the afterburner.tga is linked directly through 3D model as a mesh so it isn't related to the declaration in the afterburner.ini file. One supposedly reason it won't work  it would be that in SF2 TK used a simplified method having just the afterburner.tga and the afterburner.ini, that's what I suspect.

I need the afterburner.ini as well because I want to compare it with the afterburner.ini taken from SF1, which won't work, even if they should have the same structure (game's engine should recognizes them no matter if they are SF1 or SF2 afterburner.ini right ?)

Edited by UllyB

Share this post


Link to post
Share on other sites

ahhh that will be the emitter they us...

afterburnerfire.tga  (see red text at bottom  its referenced there) uses the Afterburneremitter.ini in effects folder

probably uses shaders SF1 doesnt have.

 

[EmitterType001]
Name=AfterburnerEmitter
EmissionType=ORIENTED_EMITTER
UpdateType=NON_MOVING
MaxVisibleDistance=8000.000000
EmissionRate=0.000800
EmissionVolume=0.010000,0.010000,0.010000
EmissionVelocityTableType=CONSTANT
EmissionVelocity=0.000000,-120.000000,0.000000
HasLightSource=TRUE
LightColor=0.405,0.396,0.342
LightRange=200.0
LightSrcOffset=0.0,0.0,0.0
SubLightSourceX=TRUE
SubLightSrcDist=5.0
ParticleUpdateType=SIMPLE_POINT
ParticleRenderType=SPRITE
ParticleRandomOrientation=FALSE
ParticleLifeTime=0.030000
ParticleLifeTimeDeviation=0.035000
ParticleWeight=-0.10000
ParticleRandomness=0.010000
ParticleDragFactor=18.000000
ParticleInheritence=0.900000
ParticleColorTableType=TABLE
ParticleColor[01].Time=0.0008000
ParticleColor[01].Value=0.500000,0.580000,0.560000,0.810000
ParticleColor[02].Time=0.200000
ParticleColor[02].Value=0.150000,0.150000,0.150000,0.00900
ParticleColor[03].Time=0.700000
ParticleColor[03].Value=0.100000,0.080000,0.060000,0.001000
ParticleColor[04].Time=1.000000
ParticleColor[04].Value=0.000000,0.000000,0.000000,0.000000
ParticleSizeTableType=TABLE
ParticleSize[01].Time=0.000000
ParticleSize[01].Value=0.450000
ParticleSize[02].Time=0.250000
ParticleSize[02].Value=0.430000
ParticleSize[03].Time=0.500000
ParticleSize[03].Value=0.410000
ParticleSize[04].Time=0.750000
ParticleSize[04].Value=0.390000
ParticleSize[05].Time=1.000000
ParticleSize[05].Value=0.360000
ParticleSizeDeviation=0.015000
TextureMaterial=AfterburnerMaterial

[AfterburnerMaterial]
EffectShaderName=twColor1.fx
DepthBufferCheck=TRUE
DepthBufferWrite=FALSE
IgnoreRenderOrder=FALSE
AlphaTestEnabled=FALSE
LightEnabled=FALSE
UseLightLevel=FALSE
SpecularEnabled=FALSE
EmissiveEnabled=FALSE
AmbientColor=0.500000,0.500000,0.500000,0.200000
DiffuseColor=0.500000,0.500000,0.500000,0.200000
ZBufferOffset=2.000000
PriorityLevel=3
BlendOp=BLEND_INV_SRC_ALPHA_ADD_SRC
NumTextureStages=1
TextureStage[01].TextureName=AfterburnerFire.tga
TextureStage[01].MipMap=FALSE
TextureStage[01].FilterEnabled=TRUE
TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE
TextureStage[01].StageAlphaOp=TEXTURE_MODULATE_DIFFUSE

 

 

 

 

 

 

Edited by russouk2004
  • Thanks 1

Share this post


Link to post
Share on other sites

So is exactly what I suspected, that's unfortunately. I hate the SF2 afterburner.tga files, they are ugly. In SF1 I had state of the art afterburner effect without any afterburner.tga meshes. Thanks for clearing it out for me.

Edited by UllyB
  • Like 1

Share this post


Link to post
Share on other sites

experiment with making some tga`s...you might get some decent results...I hate the stock one too.

or maybe try some SF1 settings in the SF2 emiitter inis....

 

Edited by russouk2004
  • Thanks 1

Share this post


Link to post
Share on other sites

I solved it! I managed to transfer the effects from SF1. All I have to find now it's a decent afterburner.tga or to make one. Thank you once again. Ideas exchange stimulated me and in the end I made it!

  • Like 1

Share this post


Link to post
Share on other sites

remember ANY effect from 1stGens are missing the shader statments. Which is why they don't work. 

  • Like 1

Share this post


Link to post
Share on other sites
35 minutes ago, Wrench said:

remember ANY effect from 1stGens are missing the shader statments. Which is why they don't work. 

Yeap, I figure this out, finally when I compared the SF1 with SF2 contain of the afterburner.ini file. Thanks. Once I discovered that it was easy to bring all the SF1 effects into SF2 environment.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..