Jump to content
Sign in to follow this  

SF2 profile issue with TARGET and T.16000M Hotas

Recommended Posts

Greetings everyone. I've returned back to Strike Fighters 2 after having decided to purchase a Hotas, so I can fly in this game properly, however it seems the Hotas I've purchased is not that great. And by that I mean the software used is kind of ... crap. I've purchased the Thrustmaster t16000m, pretty solid Hotas, but the TARGET software is just terrible. I didn't know that, otherwise I could have avoided purchasing this device, but now I have it and I cannot return it back unfortunately.

By navigating the config file included in this site, I've found the TARGET profile for T.16000M joystick and TWCS Throttle to use with SF2 series 1.0, so I've said "cool, a config is ready to be used for my Hotas", but what seemed to be an easy solution it became a very frustrating experience, and I am not sure if the script that is broken or instead is TARGET (which I suspect it is, considering the amount of complains on internet). When I plug both my Hotas and TWCS on the USB, everything works smoothly, both the USB ports are set not to be disabled for power management purposes, but when I start TARGET and loading the above mentioned script, after a while I've got the device disconnected. Also it seems to be a very random issue, because sometimes the Hotas disconnects, or sometimes the TWCS disconnects, or sometimes even both disconnects.

Here is the error from TARGET:

Physical USB HID devices managed by script!
Currently plugged USB HID devices[2]:
1: "T.16000M Joystick" - "USB\VID_044F&PID_B10A&REV_0500"
2: "TWCS Throttle" - "USB\VID_044F&PID_B687&REV_0110"
Installing filter driver to VID_044F&PID_B10A. Please Wait...Done!
USB HID device "T.16000M Joystick"(USB\VID_044F&PID_B10A\6&304D54F2&0&13) selected
USB HID device "TWCS Throttle"(USB\VID_044F&PID_B687\6&304D54F2&0&12) selected
USB HID device with hardware id "VID_044F&PID_0405" cannot be found
USB HID device with hardware id "VID_044F&PID_0406" cannot be found
USB HID device with hardware id "VID_044F&PID_0407" cannot be found
USB HID device with hardware id "VID_044F&PID_0408" cannot be found
USB HID device with hardware id "VID_044F&PID_040A" cannot be found
USB HID device with hardware id "VID_044F&PID_040B" cannot be found
USB HID device with hardware id "VID_044F&PID_0409" cannot be found
Virtual HID devices managed by script!
Connecting virtual joystick...Done
Device name set to Thrustmaster Combined
Connecting virtual keyboard...Done
Connecting virtual mouse (absolute axes)...Done

main returned 0
Error: One of the selected USB devices (0) has been unplugged. Aborting script!
Aborting script (check output above for reason)...
Script stopped!

Have you ever had any issue with TARGET? A similar situation as the above one? I've read that is better to use an alternative to TARGET, such as Joystick Gremlin for instance, but I am not able to find any Strike Fighter 2 profile for that specific software so I am not sure how to make it works.

Somebody can help me with this issue? Thanks

Share this post

Link to post
Share on other sites

Is there a Thrustmaster forum you can query?  I'm a CH Products guy so I don't have a lot of experience with TM.

I googled that message and got a lot of hits. You might try that and work your way through those.

If you go into Windows settings search for Joystick and bring up that dialog do the devices show up?


Share this post

Link to post
Share on other sites

Yes, both the devices (Hotas and TWCS) are being recognized and all the tests works perfectly (axis, buttons, etc.) is just when I open TARGET and then I load up the script downloaded here that I'm getting the issue mentioned in this thread.
As I've said I am not sure if it is TARGET or the script to be faulty, because I've tried already to google the issue, and lot's of users mentioned that TARGET is a terrible software. It could also be that the script is not working properly, but what is the reason to upload something that is not working properly here? I mean, if it was broken or partially working I don't believe it would get approved to be published here (but I can be wrong).

The solution for me would be finding somebody that uses the same device and also the same script in TARGET, or somebody that uses the same device but instead has a script for a different software rather than TARGET.

Share this post

Link to post
Share on other sites

The readme mentions mucking about with the SF2 INI that defines the controls.

2) Copy the TARGET.INI file to the Controls folder inside your Strike Fighters 2 MOD folder


5) Start Strike Fighers 2, go to the Controller settings inside the Options, and select the TARGET.INI file instead of
   the Default.INI.

Not sure if you did that. Just checking. Sorry I can't be more help.



Share this post

Link to post
Share on other sites

Sorry if I took time to reply here but I had to do some tests to be sure that the issue was resolved and, for now, it seems resolved. I am to going to post here the solution I've found (extreme tedious and difficult research) in case somebody is going to have the same issue as I've got.

First of all, when you purchase this Hotas + TWCS, make sure to download only the TARGET software but not the Drivers, Windows 10 (possibly even Windows 11) has got already some Drivers for these devices, so if you install the dedicated Drivers as well they will create conflicts.

After that, make sure to follow these instructions I've found on a forum:


Windows 10's power management features are needlessly aggressive for a desktop gaming machine. They work well for tablets and laptops, no doubt, but they're meant for people lying on a sofa reading news websites or messing around on Facebook, not gamers. If you run a TARGET script, the joystick will be replaced with a Thrustmaster Virtual Game Controller (Root). You can check whether this is active by hitting the Super key, typing "joy.cpl" and running that program (it's the Game Controllers applet). It will list all the attached joystick devices in a human-readable format. If you see "Thrustmaster Virtual Game Controller (Root)," then Windows will actually shut off the power to the USB port that the stick is connected to because it believes that the device "T16000.M" has been disconnected. :rolleyes:

To fix this, there's a really useful program called USBDeview (search it on Google).

    - With the joystick connected and TARGET not running, run USBDeview as Admin.
    - Find the T16000.M entry.
    - Right click and select "Open in RegEdit".
    - Regedit will open with the device ID highlighted.
    - Expand the registry entry (click on the arrow.)
    - Click the "Device Parameters" folder (don't expand the entry; you don't need to.)
    - There is an entry for "EnhancedPowerManagementEnabled". Double click on it.
    - Change the DWORD value from 1 to 0.
    - Restart your computer. Windows should no longer send the device to sleep. (it should work even without Restarting the PC)

This change is often reverted automatically by Windows on an update, so you'll need to change it back from time to time.

Also, if you are connecting the two Devices (Hotas and TWCS) on a front USB panel, make sure to plug them on a different set. For example, on front of my case there are 2 USB-3 ports and 2 USB-standard ports, and if you connect both the devices on the 2 USB-3 ports, one of them will got disconnected, recreating the above issue, but if you connect (for instance) the Hotas on the USB-3 port and the TWCS on the USB-standard port, everything works like a charm.

It was a pain in the - - - to make everything working, thanks to the poor Driver management of Thrustmaster but also the invasive Power management of Windows, but if you follow all the above instructions, you will get it sorted!

Thanks for your support anyway, really appreciated. And thanks for all your hard work to create all these mods for this great game!

Edited by AxtonJT
  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Thunderone
      I have been playing Strike Fighters 2 since past few years using a Keyboard. But I recently borrowed a HOTAS from a friend who wasn't using it anymore. After installing the latest driver in my PC, the HOTAS identified by the game as well (Strike Fighters 2 full package, updated till March 2012). However, I am confused when it comes to setting up the controls. The buttons on the HOTAS are very well functioning (after adding via SF2 Key Mapping menu), but the game is not recieving any input from Throttle and Stick at all. Both systems are fine, no issues as Logitech Software also acknowledges the throttle and stick movement. 
       So can somebody please help me out in fixing this issue? 
      Thank You
    • By ironroad
      When it comes to us flight and space simmers we have been pretty much left out in the cold the last decade or so.
      Most companies have gone the console or racing sim/game route when it comes to accessories.
      Came across this because for over two years I have been looking for an alternative to the now defunct Joylock Clamp system.

      29.95 USD, not sure how much they charge for shipping, but looks like it holds some promise.
      The L-bracket is 21.95.
      http://www.altrider.com/rotopax-l-bracket/pid/398and sold by a different company.
      Before I got my current desk, the Ikea Fredde, I used of metal braces and L-shaped brackets to make a mount for my X65 HOTAS system.

      The brackets worked; but the system was fixed, the corners were sharp and dangerous, and it required drilling into the desk to mount it.
      Not sure what the shipping would be for the above clamps and for those in North America/The Americas, I believe these objects ship from Europe or the UK (not sure).
      More information and examples of use can be found on the Roberts Space Industries form (link above).

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..