Jump to content
Sign in to follow this  
Nixou

Graphical enhancement mod for TW games

Recommended Posts

Graphical enhancement mod for TW games


Graphical enhancement mod for TW games

 

 

Wanna use today graphic features in the old fashion Wings of engine?

 

This mod when activated enables the Bloom feature ingame, a color correction

 

and an antialias filter, so you can enjoy the sunshine.

 

Those settings are configurable through ini file.

 

YOU MUST HAVE A RECENT GRAPHIC CARD THAT INCORPORATES PIXEL SHADING FEATURE TO USE THIS MOD!

 

 

Graphical mod enhancement presentation on youtube, part2 of the video: http://www.youtube.com/watch?v=c8eFRHwq7cM

 

*Installation:

 

-Drop D3D9.dll file directly into you TW game folder

-Drop the enbseries.ini file into the flight folder

 

If you are using any clouds mod at the same time (widesky...) rename the enbseriesMOD by enbseries.ini

 

and place this one instead of original.

 

Shift-F12 to activate/desactivate it ingame. You can tweak the ini file to configure settings as you wish.

 

Caution!!:This mod eats graphic card for breakfust and CPU for lunch, i would advise you :grandpa: not to use it if

 

you are under 50FPS during general playing without it. It would make 50frames to drop to 30 frames approximatively,

 

If you are at 30 frames you would drop to 20 frames, so don't be surprised.

 

 

 

Please before any other use than purely personnal, read the license.txt. Thx.

 

Have fun.


 

Share this post


Link to post
Share on other sites

Hey Nixarass. Nice mod, Excellent work!

 

 

One teensy problem.... The clouds in-game are mega blocky, really nasty.

 

I'm running the WideSky mod, is this the issue?

 

Can I tweak around this? And if so, which value needs changing?

 

Wo* has been crying out for this, much respect!

 

zodiac

Share this post


Link to post
Share on other sites

Hey guys, thanks for support.

 

I have provided an alternative corrected file for those who use another environmental mod like widesky.

 

Just redownload the file.

 

;)

Edited by nixarass

Share this post


Link to post
Share on other sites

Hey N,

 

Thanks for taking the time to sort out an update, it's much appreciated.

 

While you were doing that I was busy tweaking the INI and found that this worked for me, (although the horizon is still too bright to see the HUD :blink: !! I'll get it right if it kills me :blind: !)

 

 

[PROXY]

EnableProxyLibrary=0

InitProxyFunctions=1

ProxyLibrary=

[GLOBAL]

UseEffect=1

AlternativeDepth=1

AllowAntialias=1

BugFixMode=0

SkipShaderOptimization=0

QuadVertexBuffer=0

[EFFECT]

EnableBloom=1

EnableOcclusion=0

EnableReflection=1

EnableMotionBlur=0

EnableWater=0

EnableShadow=0

DepthBias=0

[iNPUT]

KeyUseEffect=123

KeyBloom=120

KeyOcclusion=121

KeyReflection=122

KeyCombination=16

KeyShadow=119

KeyWater=118

[REFLECTION]

ReflectionPower=1

ChromePower=1

UseCurrentFrameReflection=0

ReflectionQuality=0

ReflectionSourceSpecular=100

ReflectionSourceTFactor=100

UseAdditiveReflection=0

ReflectionDepthBias=0

UseLowResReflection=0

ReflectionSinglePass=1

UseEnvBump=1

EnvBumpAmount=100

EnvBumpOffset=100

[bLOOM]

BloomPowerDay=1

BloomFadeTime=10

BloomConstantDay=1

BloomQuality=0

BloomScreenLevelDay=60

BloomCurveDay=2

BloomPowerNight=25

BloomConstantNight=5

BloomCurveNight=0

BloomScreenLevelNight=20

BloomAdaptationScreenLevel=80

BloomAdaptationMultiplier=100

BloomAllowOversaturation=1

[sSAO]

UseFilter=0

OcclusionQuality=2

FilterQuality=2

DarkeningLevel=0

BrighteningLevel=0

IlluminationLevel=0

AdditiveIlluminationLevel=0

UseAmbientOcclusion=50

UseIndirectLightning=0

FadeDistance=50

[colorCORRECTION]

DarkeningAmountDay=0

ScreenLevelDay=60

ScreenLevelNight=20

DarkeningAmountNight=20

GammaCurveDay=10

GammaCurveNight=2

ColorSaturationDay=30

ColorSaturationNight=0

UsePaletteTexture=0

[PLUGIN]

WeatherMod=

[WATER]

UseWaterDeep=1

WaterDeepness=20

WaterQuality=0

[sHADOW]

ShadowFadeStart=40

ShadowFadeEnd=80

ShadowAmountDay=60

ShadowAmountNight=30

ShadowScreenLevelDay=60

ShadowScreenLevelNight=20

ShadowQuality=0

UseShadowFilter=0

FilterQuality=1

ShadowBlurRange=30

[ENGINE]

ForceAnisotropicFiltering=5

MaxAnisotropy=5

ForceDisplayRefreshRate=0

DisplayRefreshRateHz=60

[MOTIONBLUR]

MotionBlurQuality=2

MotionBlurVelocity=10

MotionBlurRotation=10

 

Many, many thanks M8 for making a good game better yet.

 

Z

Share this post


Link to post
Share on other sites

Ok, thanks. ATM i'm very busy but later on today i'll look your file to find a solution.

 

Normally with bloompower at 1, horizon shouldn't be too shiny, but with widesky mod, the white pixels of clouds provocate the bloom to "over activate" what would make it too much bright.

 

Anyway there is always a solution and as a fact i launched by error in my trials a version of widesky in which bloom was not sufficiently powerful :haha: lol, so don't worry .

Edited by nixarass

Share this post


Link to post
Share on other sites

Ok N, thanks for the life-line.

 

When the green spots have gone from my eyes I'll give it a go! Lol :biggrin: !

 

By the way, that's a BEAUTIFUL presentation on youtube, magical. (Fine bit of flying too!)

 

 

Peace,

 

Z

Share this post


Link to post
Share on other sites

Ok, i've tried your file and, it does not seem to be overbloomy. You reduced nearly all the bloom settings,

 

it seems that the last solution to reduce bloom shine is:

 

[bLOOM]

BloomPowerDay=1

BloomFadeTime=10

BloomConstantDay=1

BloomQuality=0

BloomScreenLevelDay=60

BloomCurveDay=2

BloomPowerNight=25

BloomConstantNight=5

BloomCurveNight=0

BloomScreenLevelNight=20

BloomAdaptationScreenLevel=80

BloomAdaptationMultiplier=100

BloomAllowOversaturation=0

 

Set the BloomAllowOversaturation value to 0, then try it and play with shift-F12 to see difference between stock and mod. The bloom effect should be very slight. Then report to me if it's still too much bright.

 

Regards.

Share this post


Link to post
Share on other sites

I am using widesky clouds and the relative version of the enbseries

Everythign works well, but at times, clouds turn "blocky" like int he previous enbseries versions? why is that?

Share this post


Link to post
Share on other sites

Canadair: ATI or not ATI?

 

That would probably answer half of the reason why.

Share this post


Link to post
Share on other sites
Canadair: ATI or not ATI?

 

That would probably answer half of the reason why.

 

Not ATI. Nvida 9600GT. What is strange is that all is well, than, after a random time clouds turn blocky. I am testing zodiac's entries now.

Share this post


Link to post
Share on other sites

I guess you didn't change anything on the INI file?

 

How much time about it goes blocky after being well?

Share this post


Link to post
Share on other sites

I dont know how useful this is for individual cases, but theres a Feb update from Nvidia that made peace with this mod atleast at my end ...check their site out...so far Im one happy f*cker! :rolleyes:

Share this post


Link to post
Share on other sites

NICE MUSIC AND VIDEO.

the best 8 minutes spent on this whole week.

Damn! I really liked.

And the best comparisons were sound.

Among the guns.

SAME

 

I give you 5 stars and I download this

 

 

2ba42e80288bf934927c4cdd7a6b9b5do.jpg

 

 

 

Marcos

Share this post


Link to post
Share on other sites

Really good work!

but the anti-aliasing works?? I have changed this line in enbseries.ini:

 

AllowAntialias=1

I not sure if this worked...

 

again this is a great work

(sorry my english) :))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..