Jump to content
Sign in to follow this  
SeaWulf

Windows 7

Recommended Posts

Has anyone had any experience with Windows 7 and OFF? Currently have Vista 64 bit and was wondering if OFF can be run under Windows 7?

 

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi SW,

 

Don't know for sure, but apparently OFF runs happily on W7. Email the devs at ODB and I think they're likely to confirm this.

Share this post


Link to post
Share on other sites

I recieved and installed my copy of W7 (32-bit) yesterday. So far I've tested only CFS3 on it, and that runs fine apart from the FFB stick being totally fubar. I intend to get OFF installed today.

Share this post


Link to post
Share on other sites

Working here too! (though I am loath to stick it on my 'bestest computer just yet!...it will happen though no doubt)

Share this post


Link to post
Share on other sites

Looks like I'm stuffed. Zero FFB in OFF (including no spring-pretension whatsoever, which leaves the stick flopping about and useless) and in CFS3 it's either zero or the stick pulls fully back and stays there. I've installed the Saitek drivers "Vista & Windows 7" for both the stick and rudders, tried setting them in compatibility mode for "older programs" (in the Saitek properties window), calibrated them both in and out of the game, no joy (stick...har har). I get no throttle in OFF either (works in CFS3).

 

Anyone have any ideas, or is this a W7 thing? My stick is a Cyborg Force 3D by the way.

Share this post


Link to post
Share on other sites

As much as I'd like to upgrade to 7, I just downgraded back to XP from Vista, and OFF is now running beautifully. I'm not going to mess with it now.

 

When I build (or buy) a new rig, I'll upgrade then...

Share this post


Link to post
Share on other sites

anybody else has this FFB problem with win7?

i'm waiting myself for a copy and losing FFB would be a too costly price for me.

i have a saitek evo force.

Share this post


Link to post
Share on other sites

I could be wrong but - didn't some players say that OFF MP does NOT work in

W7?

 

Can anyone confirm or deny this?

Share this post


Link to post
Share on other sites

I deleted all the control assigments except the axis, which improved things (the throttle worked at least) but the stick was still very sloppy and gave FFB only under extreme maneouvers. Zero centering force to talk of. The thing is it was never that good under XP either. The stick works ok in W7, just not in the game (CFS3 and OFF).

 

The stick I'm using now has a good centre-spring, so all I'm really missing is the MG rumble (if I keep telling myself that I won't miss the FFB so badly).

Share this post


Link to post
Share on other sites

Well, having not used a FFB stick, there's nothing for me to miss...though I think I will be with XP for a while yet (just until the dust settles)

Share this post


Link to post
Share on other sites

Please excuse my rudeness, but I'm grasping at straws, in the vain attempt to stay afloat. I also use the Cyborg EVO, but without the program. And a Logitech Gaming Keyboard to replace that terrible throttle placement on the EVO

 

If the FFB works that way, I predict the sales of the Logitech to skyrocket

 

And to be doublely insulting, please doublecheck FFB, allowed in Workshop

 

How do you mean, "without the program"? You mean the separate programming software or the drivers?

 

And yes, FFB was enabled in the Workshop and in the CFS3/OFF Manager control window. I think it's pretty much a case of MS farmed-out the netcode and FFB code in CFS3 to some bunch of shonky 3rd-rate programmers like Bohemia Interactive.

Share this post


Link to post
Share on other sites

Yes, without anything, the joystick is supposed to be 'plug and play' so plug in the USB and let Windows provide the driver, if there's no FFB then, there is no hope

 

All calibration will be via the control panel > Properties

 

Any assignments of Button Function, will be provided in the Controls of OFF

 

I'll give that a go, but I'm pretty sure I gave the stick a go in W7 before I loaded the drivers and there was nada going on with it.

Share this post


Link to post
Share on other sites

I quite honestly can't see the point of 'upgrading' to 7 if you have XP. It doesn't seem to do anything over and above XP that I want. And XP is stable. Although maybe I am biased because I have a Volume License Copy of XP which doesn't have to be 'activated'.

Share this post


Link to post
Share on other sites

I think it's pretty much a case of MS farmed-out the netcode and FFB code in CFS3 to some bunch of shonky 3rd-rate programmers like Bohemia Interactive.

 

I believe that's BOHICA Interactive you're thinking of. :grin:

Share this post


Link to post
Share on other sites

I could be wrong but - didn't some players say that OFF MP does NOT work in

W7?

 

Can anyone confirm or deny this?

 

Can't comment on BHaH, but P2 and CFS3 itself don't work on the pre-release versions of Windows 7. I've tried it with both 32-bit and 64-bit versions and CTD is the result every time. The 'Vista fix' for CFS3 doesn't help either.

 

I don't know about the final code for Windows 7, my copy is still with the carrier.

Share this post


Link to post
Share on other sites

I quite honestly can't see the point of 'upgrading' to 7 if you have XP. It doesn't seem to do anything over and above XP that I want. And XP is stable. Although maybe I am biased because I have a Volume License Copy of XP which doesn't have to be 'activated'.

 

I need to learn W7 for my work, but it just so happened that the day before W7 arrived I started to get multiple crashes in at least three games with the dreaded "nv4_disp" error. That was after I'd been trying lots of different drivers with my new GTX285, and it had clearly corrupted the OS.

 

I am getting minor jerks and stutters with OFF in W7, despite very high FPS, something that didn't happen under XP with a lesser card (GTX8800), but it's not a show-stopper, just irritating.

Share this post


Link to post
Share on other sites

Hehe, I remember when XP came out. It totally, completely sucked for the 1st 6-12 months. Maybe those of you all who love XP so much today have forgotten that grin.gif.

 

It's always the same when a new OS comes out. The OS itself will have a number of bugs and few if any of the drivers intended for it will actually work well or at all. It thus always takes at least 6 months, often more, to get these problems sorted out. The early-adopters have all kinds of problems and a generally rotten time, but their sacrfices are what get the problems solved for those who wait.

 

So, I salute all you early-adopters with Win7, and look forward to getting a good OS with good drivers sometime next year, about when I get a new computer. I drink to your bravery in exploring this new environment drinks.gif

 

 

Share this post


Link to post
Share on other sites

I hope my last post didn't mislead anyone, I mean Windows 7 won't work with Multiplayer - QC and missions work just fine. XP is a great OS, which is why I have a dual-boot setup with XP Pro on the other HD to cater for the apps I still use which need it.

 

I really like Win 7 as a working environment. Look on it as "Vista fixed" if you like, and I hated Vista.

Share this post


Link to post
Share on other sites

I could be wrong but - didn't some players say that OFF MP does NOT work in

W7?

 

Can anyone confirm or deny this?

 

 

thats true,,,as confirmed by madmatt....has something to do with w7 either not intrepreting xml files at all,,or interpretting them wrong...

Share this post


Link to post
Share on other sites

Hehe, I remember when XP came out. It totally, completely sucked for the 1st 6-12 months. Maybe those of you all who love XP so much today have forgotten that grin.gif.

 

 

 

I for one haven't forgotten that..and in fact, it continued to suck right up until the release of SP2

But Vista sucked when it came out...continues to Suck..and (IMHO) will continue to suck for ever more!..Hence the arrival of W7 is welcomed...Just installed it on a Clients Laptop (overwriting Vista) and touch wood...looking very good indeed!..didnt have to search for drivers at all!!...brilliant

 

Though one small nuisance..maybe just something I need to do..is that you cannot 'Run' a program from the net..I just tried to run AVG...but it doesn't open the program..had to download it, then run it...nothing major though

Edited by UK_Widowmaker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.