Jump to content
Sign in to follow this  
PhilEAF92

Sounds cause mini pauses ?

Recommended Posts


Most gaming PC's have THREE processors. The first is the CPU (Computer Processor Unit, i.e. the computer chip), the second is the GPU (Graphics Processor Unit, i.e. your video card), and the third is a APU (Audio Processor Unit, i.e. audio card). If you only have a CPU and GPU, that means your CPU has to process both the game and audio (sounds) which can cause stuttering at times due to the high load.

 

If you have all three processors, the stuttering could be due to an IRQ conflict (two pieces of equipment both trying to use the same path at the same time in the computer).

Share this post


Link to post
Share on other sites

Have seen exactly same problem on my laptop. Samsung R780, Win 7 Home, Intel Core i3-330M 2.16GHz, nvidia GT-330M 1GB, 4GB Memory, but. . . Onboard sound, Realtek drivers.

 

You could try this solution:-

 

http://combatace.com/topic/57617-sound-problem/page__gopid__441389

 

Regrettably, I have found that my batch conversion has not completely cured the issue.

 

Standard MS drivers may help, although it didn't in my case.

 

My interim solution is to rename the speech folder so the game can't load sounds. No voices . . but mostly no stuttering. Sadly I think it is a case of pure processing horsepower being marginal, especially with onboard sound.

 

Complete defrag and re-install may help a bit, bit that is extreme for a heavily modded install.

 

Otherwise, the usual advice about closing down all non-essential services and so freeing up CPU cycles is probably good here.

 

Cheers,

 

Baltika

Edited by Baltika

Share this post


Link to post
Share on other sites

When certain sound effects, largely speech are played the game pauses moment, can someone tell me a solution, because its ruining this beautiful smooth game.

 

 

What patch are you running?

What system?

 

Are you using an Ati card? - if so set it to let the application decide on Anti Aliasing and Anistropic Filtering levels

Share this post


Link to post
Share on other sites

PCI latency issues. I once experienced this same issue a few years ago, when I was running SF:P1 on a system based on an N-Force chipset. Adjusting the PCI-latency of my video card down from 256 to 64 helped, as did ensuring that my TB Santa Cruz sound card was set at 32.

 

http://www.soundonsound.com/sos/oct04/articles/pcnotes.htm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..