Jump to content
Sign in to follow this  

M1 Tank Platoon 2 - possible fix for crash/CTD at end of mission

Recommended Posts

Many have got Microprose's classic modern tank sim M1TP2 working on recent versions of Windows and in Glide mode's better graphics thanks to Zeus's nGlide wrapper. However, some like me still get a Crash To Desktop when they end a mission. This seriously inhibits playing M1TP2's excellent campaigns, in particular.
This fix has been working for me...so far...! Posting here as I haven't seen this one elsewhere. I'm using NGlide - Zeus's 'experimental' patch (http://www.zeus-software.com/forum/viewtopic.php?f=10&t=259&hilit=m1tp2&start=30#p2431), untested with other versions, Vista 64.

Here's what I did that made the difference. In the Compatibility tab of M1TP2.exe, as well as setting Compatibility Mode to 'Windows XP SP2', in the same tab (Compatibility) I checked both 'Disable visual themes' and 'Disable desktop composition'. Not sure if one or both are needed but no matter.

Before that, I got a CTD after every mission. Now, the missions end normally (just the training ones tried so far) with the debriefing and video clips. Here's how my Compatibility tab looks now:


M1TP2 2014-06-08 19-09-55-81.jpg

I'm not using the starter.bat file recommended by some. There's no menu corruption (GTS 250 with recent drivers); my only minor issue now is there's no 'exit' button on main screen so I need Alt+F4 to exit the game, when I'm done.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By agathosdaimon
      I have recently gotten WOE working on windows 10, thanks to help in another thread on this forum, and now have installed the Operation Desert Storm mod and it is all looking and running nicely except fro teh Instant action option, where the  game will just crash if i select it from the menu - can anyone help me as to why this would be happening. I looked in teh options.ini and the instant action has DS selected as its map so i dont understand what the critical error is here
      has anybody else encountered this?
    • By TempestII
      Hello gents,
      My full SF2 install has suddenly (circa a month or so ago) started crashing to desktop whenever I delete a waypoint in Single Mission Editor.  I've also noticed that it crashes more commonly on start-up, but after a couple of attempts, it'll launch to the Main Menu Screen.  However, if I delete a Single Mission Waypoint then it'll crash.  
      I've moved my modded folders to an external HDD and re-installed SF2E and the Exp Packs and yet the crashes still occur.  Any help would be massively appreciated.
      The only hardware upgrade I've done to my PC recently was to upgrade my GPU from a 980TI to a 1080TI; it definitely worked fine when I first did this but I have read the Nvidia thread on here that some users have had problems with recent software updates (I've made sure that my Effects aren't on "Unlimited" although none of the issues I've read in that thread seem to match what my issue is).  I did a search but couldn't find any similar CTDs either so I'm rather stumped.
      PC specs are in my sig if that helps.  Thanks in advance.
    • By Spudknocker
      Hey CA for some reason that I cannot figure out my WW2 install crashes directly to the desktop every single time I hit the Fly! button.  This happens with every terrain and every aircraft.  I tried creating a new Mods folder that didnt work then tried making a new mods folder with a different exe and that didnt work either, Ive tried reinstalling the Terrains and aircraft all to no avail :( I am out of ideas... does anyone have any?
    • By Spudknocker
      Hello CA!  I thought i would share this little tidbit I stumbled across late at night (couldnt sleep haha)  If you have a terrain lets say for example Desert4 if you extract the Desert.cat files and place all the files in the desert4 folder (being careful not overwrite any of the custom files in the desert4 folder) and then slash out the .cat file statement in the terrain.ini file this can DRASTICALLY reduce load times and potential crashes.  I believe this is due to the fact that the game engine doesn't have to unpack the compressed CAT file to find the missing pieces stored within it.  Ive tried this with multiple terrains all the to same great effect (CubaOTC and Iran-Iraq etc)  
      The second thing ive discovered is that the File name callouts in the terrain.ini folder for example NationsFile=DESERT4_NATIONS.INI etc ARE in fact CASE SENSITIVE now using Windows 10, this wasn't the case before using Windows 8.1 and this has helped avoid issues with nations and flying CAS missions in seemingly random areas of terrains haha.  If any of this is old info I apologize but this has kinda been a light bulb moment for me and has alleviated a lot of frustrating issues.
    • By JakeGrafton
      In SF2NA, I've installed 331KillerBee's Ordance Shop (all of it) and now get a CTD when I attempt to use any weapon (or raise landing gear, in some cases) on any plane.
      Could anyone suggest? Thanks! - Jake

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..