Jump to content

Recommended Posts

man, I gotta say, that has one of the, if not THE best cockpit's I've seen in like, forever!! (sorry stary!)

 

but, I'm (well, was) having problems with the AI controlled wingmen mushing into the ground on take offs.

 

So, I located a 'like sized' aircraft, and used those aerodynamic parameters. it seems to have helped greatly. mind you, it may be 'better' than real life. this is just a quick and dirty fix (engine power is also upped - maybe too much)

 

so, here's a attached zip with the "newish" data ini, a destroyed model, and the new sf2 'box art' hangar screen. Also the AvHistory Allison 1710 engine sound.

canopy was switched to the Shift/0 animation key (sorry brother R!)

 

BACKUP THE ORIGINAL DATA INI FIRST BEFORE INSTALLING THIS!!!

 

PLEASE test and report. there is still some bounce and the 'tire touch' sound at mission start... I just don't know what's up with that.

frakking 5/13 patch no doubt

Share this post


Link to post
Share on other sites

forgot the mention this is JUST for the USAAF version. I haven't installed the MTO RAF one yet!

Edited by Wrench

Share this post


Link to post
Share on other sites

Thanks ,the pit is what took so long. I'm getting the 'tire touch sound' with the 06 patch also so I'll look at it, I think it's in the tailgear animation. I'll give your new data a try, I had issues with the wingman also. (I might update the pit with wiring). 

Share this post


Link to post
Share on other sites

I do a FM fix on my own (WOE 08), I don't think I will release it.

 

But here's some parts :

 

For the landing gears, in the data.ini file

 

[TailGear]
SystemType=LANDING_GEAR
Retractable=TRUE
DeployTime=8.0
AnimationID=1
DragArea=0.25
HideGearNode=TRUE
ModelNodeName=GearT
InsideNodeName=TWWell
ShockAnimationID=4
ShockNodeName=TG_Pivot
//ShockTravelAxis=Z-AXIS
ShockStroke=0.08
SpringFactor=0.9
DampingFactor=0.8
WheelNodeName=Tail_Wheel
//RotationAxis=X-AXIS
RollingRadius=0.142
CastoringWheel=TRUE
CastoringNodeName=TW_Yoke
Steerable=TRUE
MaxSteeringSpeed=50.15
Locking=TRUE
MaxSteeringAngle=45.0
InputName=YAW_CONTROL
ControlRate=3.0
HasBrakes=FALSE
RollingCoefficient=0.05
MaxDeploySpeed=78.71

 

[LeftMainGear]
SystemType=LANDING_GEAR
Retractable=TRUE
DeployTime=8.0
AnimationID=1
DragArea=0.85
HideGearNode=FALSE
ModelNodeName=PivStrutMain_L
InsideNodeName=
ShockAnimationID=3
ShockNodeName=LM_Shock
//ShockTravelAxis=Z-AXIS
ShockStroke=0.15
SpringFactor=1.0
DampingFactor=0.75
WheelNodeName=L_Tire
//RotationAxis=X-AXIS
RollingRadius=0.380
CastoringWheel=FALSE
HasBrakes=TRUE
BrakingCoefficient=0.75
RollingCoefficient=0.05
MaxDeploySpeed=78.7

 

[RightMainGear]
SystemType=LANDING_GEAR
Retractable=TRUE
DeployTime=8.0
AnimationID=1
DragArea=0.85
HideGearNode=FALSE
ModelNodeName=PivStrutMain_R
InsideNodeName=
ShockAnimationID=2
ShockNodeName=RM_Shock
//ShockTravelAxis=Z-AXIS
ReverseShockOrientation=FALSE
ShockStroke=0.15
SpringFactor=1.0
DampingFactor=0.75
WheelNodeName=R_Tire
//RotationAxis=X-AXIS
ReverseModelOrientation=FALSE
RollingRadius=0.380
CastoringWheel=FALSE
HasBrakes=TRUE
BrakingCoefficient=0.75
RollingCoefficient=0.05
MaxDeploySpeed=78.7

 

For the canopy, if the animation key 10 is used, in the cockpit.ini file :

 

[Canopy]
Type=EXTERNAL_ANIMATION_LINK
NodeName=CanFrm_In
MovementType=POSITION_Y
Set[01].Position=0.0
Set[01].Value=0.0
Set[02].Position=-0.7
Set[02].Value=1.0
ItemNumber=5

 

[CrankCanopy]
Type=EXTERNAL_ANIMATION_LINK
NodeName=CrankPl
MovementType=ROTATION_x
Set[01].Position=230.0
Set[01].Value=0
Set[02].Position=590.0
Set[02].Value=1.0
ItemNumber=5

 

This model is a beauty, AWESOME!!!

Thank you a billion times ; )

Edited by Cliff11

Share this post


Link to post
Share on other sites

The plane and cockpit are simply brilliant. The problem is to make it fly without the horrible bouncing and explosion. The plane itself starts as close as 1.5m from the ground floating like a baloon and then falls like a rock!!!!! What a shame TW...

Share this post


Link to post
Share on other sites

wilches:

 

have you TRIED the data ini I posted above???

 

give it a shot, and see what you think (after all, you are one of the ex-EAW dudes)

Edited by Wrench
spelling correction

Share this post


Link to post
Share on other sites

Tire touch sound fix , Needed for all of my hurricanes also:

 

[AIData]
//TakeOffRotationAngle=20.0 <----Coment out.

 

Didn't fix it 100% but better, Darn thought I had it nailed.

Edited by RAVEN

Share this post


Link to post
Share on other sites

Ok, the game is spawning the wingman tail high, then it drops (touch sound) I tried to export with the PP moved, no joy. ???

Share this post


Link to post
Share on other sites

Guys, with all the tips given above and the following lines the result is very good. Not the final fix but much better indeed.

 

[AircraftData]

CGPosition=0.00,-1.10,0.00
CockpitCGOffset=FALSE
OnGroundPitchAngle=20.0

 

[Engine]

PropDiameter=1.352

 

As I stated before, the CG is the main cause of this mess. Have a try and describe your results please.

Share this post


Link to post
Share on other sites

doesn't changing the prop diameter change the engine performance curves? or is that only for "collision" calculating?

Share this post


Link to post
Share on other sites

Well... I doubt that all of us are using the same install, with the same patch, with the same set up.

 

"The CGPosition= data under [AircraftData] in data.ini relates the cg position relative to the pivot axis position of the 3d model, and this shouldn't directly affect the flight model.

The only place CGPosition= affect flight is when determining moment due to force (say from gunfire, bomb release, etc)"

 

and I think it's true.

 

And think that the engine dry weight value is 1645lb (746kg) ...do you think the tail weight has the same value?

 

Original FM gives the nose : 660kg

Wrench's temporary fix : 500kg

 

And the nose is engine + propeller screw + nose + oil (at least)

Edited by Cliff11

Share this post


Link to post
Share on other sites

Concerning the CG, is right to say that it changes the plane flight behavior BUT TW, for an unknown reason, mess with the CG somewhere forward (my guess is around 50cm - half a meter) so when you place the CG to 50cm backwards you´re actually correcting the CG to it´s original position.  What we must know is the correct value. I´ve tried this on other props and the result was the same - no falling and explosion.

Share this post


Link to post
Share on other sites

well, I used your values, Wilches, and it got WORSE!

Of course, this on my data ini posted above, 5/13 patch. Mains and tail wheel were above ground, in fact the aircraft was level with respect to the ground, then dropped. Went back to my originals, and all I get is slight chrip.

left the prop at YOUR values, however (just in case! :biggrin: )

 

maybe moving the CG to -0.50, and keep experimentating? Usually what I do, is .25m increments in (whatever) direction. Time consuming? Hell yes!! :blink:  

 

Raven, is the aircraft's world center 0,0,0?? Wish we had something TK-ish to compare with, like his Spits or mustangs

Share this post


Link to post
Share on other sites

I set the CG to 0.00,-1.00,0.00 and made no other changes, the wingman is now spawned on the ground, still a little bouncy. World center is at the Center of lift (6% of MAC)

post-300-0-14591300-1370898231_thumb.jpg

Edited by RAVEN

Share this post


Link to post
Share on other sites

Wrench can you get me a screenshot of the TW P-51 With a decal at 0.00,0.00 on the fuselage? I've been compairing the Max Extents of the P-40 with the TW P-51D (have Data.ini) and I'm 98% sure that it's exported in the correct place. I'm off to work, back at midnight.

Share this post


Link to post
Share on other sites

That matches the offset when I compared the Max Extents . I'll try an idea I have and get back to ya.

Share this post


Link to post
Share on other sites

TKs Mustang.

BUT ONLY the aerodynamic descriptions ABOVE the crew section (the usual stuff, left wing, inner and outer, nose, tail, etc)

I left the weight and empty inertia statemets alone. the wing area, chord, etc were "close enough". left the control statements alone. after all, its NOT a mustang!!

 

like I said, NOT a perfect fix, but workable, or a starting point. I DID boost engine power as a cheat --and I hate doing that!!

 

look at mine and compare to the Raven's original ( you DID backup the original, right??? :biggrin: )

Share this post


Link to post
Share on other sites

Yes I will compare both FM values, and that's the "workable, starting point" I was asking.

 

I'll try to keep the engine power as it is and I'm doing the test flight take-offs with flaps 0.

Or am I wrong and P-40 were taking off with flaps extended?

 

Edit : edit deleted xD, sorry, still searching...

Edited by Cliff11

Share this post


Link to post
Share on other sites

I checked all my collected data and found nothing on flaps at takeoff.

Just found: " Take-off ( weight 8100lb)  (using Military Power and Flaps 30')" Speed - 93 MPH.

Tested ingame , 112,34 MPH

Edited by RAVEN

Share this post


Link to post
Share on other sites

Great! I'll try that

 

For landing, is that close to correct?

 

Full flaps : 45°

Gears : extended (...it's better :haha: )

IAS : 110 MPH

RPM : 2000 (had to push to 3000 in short final sometimes)

Elevator trim up : 4 or 5

Edited by Cliff11

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.