Jump to content

Recommended Posts

I recently reinstalled SF2,E,V,and I (NA didn't install for some reason) and been getting constant CTDs when opening all of them. Any help would be nice as I can reinstall it but fear that Windows 10 (I tried Windows 8 compatibility but no joy) is the bane of SF2.

Share this post


Link to post
Share on other sites

Thanks both as I wanted to get that back working just in case...

Nah, the installer doesn't install NA, even though I had bought that. Not sure if that's the reason why it CTDs. The installer seems borked as it didn't install NA and Israel as well as the two Expansion packs. I'll rerun it tomorrow and maybe it'll do it right.

Edited by EricJ

Share this post


Link to post
Share on other sites

Never mind, a computer restart fixed the issue somehow. Was a slight hiccup but now I'm slowly putting things back together.

Share this post


Link to post
Share on other sites

Okay woke up this morning and after awhile, decided to see what the old game would do (stability test really) and it's back to CTDing again, with no modifications, just vanilla SF2 and no joy. I really think something is missing as I created a Saved Games folder (maybe it's not creating that?) and no luck. So for my Saved Games (or My Games?) folder do I have to create a Thirdwire folder and then add my mods?

Share this post


Link to post
Share on other sites

The folder in saved games should be created automatically as soon as you run the exe.

Have you done a merged install? you just run the exe for each game which creates a separate folder for each one.

 If the base game is CTD then something is wrong 

Right click on the short cut and go to the compatibility tab

Tick Disable full screen optimisations and Run this program as administrator

Have you set up an NVIDIA or whatever profile?

Disable Game mode in settings

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

at this point ya might wanna mention what rig and version of 10 youre using. you are having more difficulties than the average bear it seems. but like MiGBuster said, the mod folders should be created automatically.

one other question: are you pulling the new installs from a HD back up or from TW site?

Share this post


Link to post
Share on other sites

TW site, as I didn't back up the exe files.  I don't think the Saved Games folders are creating, which may explain the CTD, it may be trying to create them and not. All of the games are CTDing, not just the base game, but I'll try the disabling optimization.

Share this post


Link to post
Share on other sites
3 hours ago, MigBuster said:

The folder in saved games should be created automatically as soon as you run the exe.

Have you done a merged install? you just run the exe for each game which creates a separate folder for each one.

 If the base game is CTD then something is wrong 

Right click on the short cut and go to the compatibility tab

Tick Disable full screen optimisations and Run this program as administrator

Have you set up an NVIDIA or whatever profile?

Disable Game mode in settings

 

 

 

 

 

 

Will look into that.

Share this post


Link to post
Share on other sites
4 hours ago, Wrench said:

can't help with Winbloze 10

its not that bad once you get used to it. I actually am more used to it now than my older backup laptop with Win7

an Eric, when it works it works with no differences. when it doesnt, it becomes a leading cause of baldness in simmers/modders.

  • Haha 2

Share this post


Link to post
Share on other sites
6 hours ago, daddyairplanes said:

its not that bad once you get used to it. I actually am more used to it now than my older backup laptop with Win7

Ditto that! Win10 used to have a number of issues at its release, but now after years of continuous updates, it's much better. Whenever I had some serious problems with my PC, I would have to reinstall Win7 and erase everything. Now it's different, Win10 can be reinstalled easily without formatting your HD. If the OS refuses to start (even in safe mode), they made it so you can access the command prompt. Thanks to this I was even able to fix a BSOD due to an antiquated DRM/driver issue, and the OS restarted correctly after doing the needed tweaks (a little search on the net pointed me in the right direction). It's a much smarter OS, so to speak. To make old games work, some old legacy components must be installed, like DirectX 9 and this: https://windowshelper.co/how-to-enable-directplay-for-old-games-in-windows-10/

Share this post


Link to post
Share on other sites

Did you install DX 9.0c? This is an issue I had a while back, once I ran the installer everything was fine.

Share this post


Link to post
Share on other sites
6 hours ago, Menrva said:

Ditto that! Win10 used to have a number of issues at its release, but now after years of continuous updates, it's much better.

back to the exact of SF2 and Win10, i participated (loosely) in the trial bit before it released. SF2 was up and down depending on where they were with each build update (on a pretty non capable desktop just for testing Win10 insider), but not a problem when i got my new laptop a year after Win10 release.

 

 

Share this post


Link to post
Share on other sites

Okay so I'm at the bad phase where my WIn 10 won't like it but other games work fine then. I'll just have to run WIndows update then or let it do its thing.

Share this post


Link to post
Share on other sites

This is strange! I have been away also because I lost my machine. After about a year I finally got a replacement and I am experiencing the same stuff Eric is! I will monitor this thread closely!

Share this post


Link to post
Share on other sites

Hello

Hopefully I'm not hijacking this post but I have the same problem.

Tried to play SF2 after several months away but am now getting CTD within seconds of opening the program.

I have SF2, SF2 Europe, Israel and Vietnam. Not NA yet - was going to buy it. Nor do I have the Expansion Packs.

It was working on my Win10 Home PC with absolutely no problems until now.  There have been several GPU driver updates and mainly a Win10 update to 1809. 

 

I have tried:

1) reinstalling several times on different drives with and without AV disabled.

2) All of the different compatibility modes, with and without Running as administrator and Disabling full-screen optimisations.

3) Rolled back my NVIDIA drivers to various early 2018 versions.

 

I am installing from downloaded files based on the following process I found on the web (not sure if it was here or the Thirdwire forum site before it closed) ages ago - it has always worked for me before for new PC installations.

1. Install the original 2009 combo – SF2_combo09_web_setup.exe
2. Strike Fighters 2 Israel Jun 2010 Update – SF2I_update_Jun2010.exe
3. Strike Fighters 2 series May 2011 Update – SF2_update_May2011.exe
4. then run – SF2_update_Mar2012.exe
5. followed by the latest update – currently - SF2_update_Jul2013

 

Any ideas would be appreciated before I give up on this excellent game.

 

Share this post


Link to post
Share on other sites

Any error messages?

What happens if you delete options.ini and versions.ini from saved games and run the game again?

Do you have an NVIDIA profile setup?

Don't suppose you know if the combo worked before applying any patches.

Share this post


Link to post
Share on other sites

Hello MigBuster

Thank you for the response.

No error messages unfortunately - that might have given me something to investigate.

I have tried deleting the .ini files and also all of the folders under Saved Games. No difference.It doesn't look like it is to do with creating the Saved Games folders.

NVIDIA profiles? Is that in the NVIDIA Control Panel or in Profile Inspector? In either they are similar and the only changes I have made is to turn vsync off.

I tried running StrikeFighters2.exe after each stage of the above install and it worked up to and including stage 2. I say "worked " but there was still one CTD with the icon left on the taskbar which when selected then appeared to run with all of the correct graphics settings for my monitor (2560x1440). This was the same for all four variants of the game. Stage 3 reproduces the problem. The annoying thing is I have had them all running well with the latest patch (2013) loaded in the past year.

The problem I have is that the game CTD but appears to be open on the taskbar and when you select it the game CTD taskbar again.

 

Share this post


Link to post
Share on other sites

Try in order:

 

In Windows Settings disable all the Game mode features if you have not done so

Security software (AV and Malware) - can you switch off any sandboxes or Anti Virus bits on a temp basis 

Do you have anything like Samsung magician running in the background?

 

Profile is NVIDIA Control Panel -> Manage 3D Settings -> Program Settings Tab -> Press Add and select game if not done already 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..