Jump to content

Recommended Posts

I'm having a little issue on a few of the terrains the ships seem to hover over the water so far I'm seeing this in the Libya map and the DBS map any ideas? the stocks and Iceland seems to be fine.

Share this post


Link to post
Share on other sites

which versions of DBS and Libya? (they've gone through a couple of changes)

 

Look in the terrain data inis, you should see this for ALL sea and sea/land transitions tiles:

 

HeightMapScale=2.000000

 

both terrains should have full black painted _HM.bmps for the sea, sea/land transition tiles

Share this post


Link to post
Share on other sites

Libya-ver375 and and i think its the latest DBS from SF2 download section It has the HeightMapScale=2.000000 fix I think.

Share this post


Link to post
Share on other sites

It's the water texture material entry in the terrainXXX_data.ini that's causing that. Make sure that it looks exactly like so:

 

[WaterTextureMaterial]

EffectShaderName=terWaterEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=TRUE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

SpecularColor=1.000000,1.000000,1.000000,1.000000

SpecularPower=10.000000

Reflectivity=0.00000

ZBufferOffset=0.000000

BlendOp=ONE

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

Share this post


Link to post
Share on other sites

Thanks for the help!! that fixed it hee hee the only time i want to see the screws is when the ship(s) are turning turtle :good:

Share this post


Link to post
Share on other sites

ALL older terrains (pre May11 I think) have to be adjusted this way from my observations

Share this post


Link to post
Share on other sites

looks like some data ini checking is ahead, and a post in the KB for a fix!!

 

thanks guys! (gonna double check and make sure)

Share this post


Link to post
Share on other sites

had the same issue with my repaint of GermanyCE when using data from late 2009, so it's as Fubar pointed out, water section that needs update, these are the key entries:

 

EffectShaderName=terWaterEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

Share this post


Link to post
Share on other sites

looks like an update is in order; this is from the wate section in DBS:

 

[WaterTextureMaterial]

//UseEffectShader=TRUE

//EffectShaderName=WaterEffect.fx

EffectShaderName=terWaterEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=TRUE

EmissiveEnabled=FALSE

 

Note the 'FALSE" have to fix that

Share this post


Link to post
Share on other sites

The ships aren't floating above the water due to any changes made by Third Wire. The answer is, however, quite disturbing.....

 

You see, it's the eels. They are converting all ships into hovercraft, for their own diabolical purposes :yikes:

Share this post


Link to post
Share on other sites

(whispers in shock)

 

they... are... back...

 

(it's full Moon night... outside, in the distance one can hear wolfs howling. Fade to black. End titles)

Share this post


Link to post
Share on other sites

In an early version of DBS, I had made hm files with random bumps.. Ships rose and fell as if riding waves, and even the wake would vary with the ships movement... Don't know if "modern" SF will do that..

Share this post


Link to post
Share on other sites

Hey guys. I just found this and tried redoing the above entries for the central Pacific terrain and I still get floating ships. Any one else have this issue with this terrain?

Share this post


Link to post
Share on other sites

Never mind. I figured it out. Some of the HeightMapScales were set at 25.000000. Change them to 2.000000 and all is good now.

Share this post


Link to post
Share on other sites

I just noticed the issue with Central Pacific today as well.

 

The following entry's in the "CentralPacific_DATA" file appear to be the issue. 

 

[WaterTextureMaterial]
UseEffectShader=TRUE
EffectShaderName=WaterEffect.fx
DepthBufferCheck=TRUE
DepthBufferWrite=FALSE
RenderedInOrder=TRUE
AlphaTestEnabled=TRUE
CullMode=CLOCKWISE
LightEnabled=TRUE
SpecularEnabled=TRUE
EmissiveEnabled=FALSE
FogEnabled=TRUE
AmbientColor=1.000000,1.000000,1.000000,1.000000
DiffuseColor=1.000000,1.000000,1.000000,1.000000
SpecularColor=0.500000,0.500000,0.500000,1.000000
SpecularPower=5.000000
Reflectivity=1.00000
ZBufferOffset=4.000000
BlendOp=BLEND_SRC_ALPHA
NumTextureStages=2
TextureStage[01].TextureName=
TextureStage[01].MipMap=TRUE
TextureStage[01].FilterEnabled=TRUE
TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE
TextureStage[01].StageAlphaOp=TEXTURE
TextureStage[02].TextureName=
TextureStage[02].MipMap=TRUE
TextureStage[02].FilterEnabled=TRUE
TextureStage[02].ReflectionMapping=TRUE
TextureStage[02].StageColorOp=TEXTURE_BLEND_TEXTURE_ALPHA
TextureStage[02].StageAlphaOp=DIFFUSE
 
[Texture001]
Filename=vietnamS1.TGA
HasWater=2
HeightMap=vietnamS1_hm.BMP
HeightMapScale=25.000000
Color=0.114571,0.204605,0.305404
SolidObjectTexture=
AlphaObjectTexture=
 
[Texture002]
Filename=vietnamS2.TGA
HasWater=2
HeightMap=vietnamS2_hm.BMP
HeightMapScale=25.000000
Color=0.109990,0.196346,0.292984
SolidObjectTexture=
AlphaObjectTexture=
 
[Texture071]
Filename=vietnamS-GJ.TGA
HasWater=1
HeightMap=vietnamS-GJ_hm.BMP
HeightMapScale=25.000000
Color=0.235268,0.319207,0.282990
SolidObjectTexture=terobject_buildings1.BMP
AlphaObjectTexture=jungle.tga

Share this post


Link to post
Share on other sites

simple text edit, find/ replace with...

 

good catch!! :biggrin:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..