Jump to content

Recommended Posts

Been on this all afternoon and give up..converting C to the K version for stopgap

 

when get in game...this is state of ...wingfold....airbrake...and hook refuses to work.

heres data for the bits...if anyone can spot my error...??

set pivot on outerwings for folding.maybe I need to use a mesh to link to wing and link outer wing to that.?

also missiles seem to have moved ...

all pylons that will move have the relevant last two same lines as here below.

 

[RightOuterWingStation4]

SystemType=WEAPON_STATION

StationID=25

StationGroupID=4

StationType=EXTERNAL

AttachmentPosition= 3.802,-2.836,-0.195

AttachmentAngles=0.0,0.0,0.0

LoadLimit=1550

AllowedWeaponClass=AHM

AttachmentType=WP

ModelNodeName=RightOuterPyl

LaunchRailNodeName=

PylonMass=72.58

PylondragArea=0.02

FuelTankName=

SpecificStationCode=AA12

MovingPylon=True

RotatingPylon=True

 

L outer and R outer wings

 

SystemName[008]=LeftWingFold (rightwingfold)

 

[LeftWingFold]

SystemType=ANIMATION

InputName=ANIMATION_10

DeploymentMethod=MANUAL

AnimationTime=6.0

AnimationID=3

 

 

[RightWingFold]

SystemType=ANIMATION

InputName=ANIMATION_10

DeploymentMethod=MANUAL

AnimationTime=6.0

AnimationID=3

 

 

[Airbrake],,,,,Parent is fuselage

SystemType=AIRBRAKE

DeployTime=3.0

RetractTime=2.0

AnimationID=2

ModelNodeName=Airbrake

DragArea=0.80

 

[Tailhook],,,Parent Fuselage

SystemType=ARRESTOR_HOOK

MaxDeflection=60.0

Retractable=TRUE

DeployTime=1.0

ModelNodeName=Hook

HookArmLength=1.608

AttachmentPosition=0.0,-5.906,0.017

post-1981-0-62088900-1357249151_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites

I usualy do the wing fold without seperating left and right and I would set the airbarakes animation to 6 and wingfold to 9

Share this post


Link to post
Share on other sites

Russ, couple of things:

 

First, if you use an Animation slot as pure animation (ie not tied to a control surface or landing gear/hook), any weapons attached to that node will not rotate properly. We encountered this with the Hornet and Super Hornets.

 

Second...silly question, but did you put the SystemNames for the Airbrake and Hook in the appropriate component section?

 

FC

Share this post


Link to post
Share on other sites

For the hook instead of SystemType=ARRESTOR_HOOK try SystemType=ARRESTER_HOOK I think thats only a type-o. Btw, nice plane.

 

Also (might not needed) RetractTime=2.0 or something similar

Edited by logan4

Share this post


Link to post
Share on other sites

this is what im using for the helldiver and its working great

 

 

[LeftWingStation2]

SystemType=WEAPON_STATION

StationID=3

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=-3.993,1.407,-0.268

AttachmentAngles=0.0,0.0,0.0

LoadLimit=370.0

AllowedWeaponClass=RCKT

AttachmentType=USN,USAF

MovingPylon=TRUE

RotatingPylon=TRUE

ModelNodeName=L02

PylonMass=5

PylondragArea=0.02

 

 

[LeftAirbrakeUpper]

SystemType=AIRBRAKE

DeployTime=3.0

RetractTime=1.5

ModelNodeName=DBrake_Lt

AnimationID=6

DragArea=1.5

 

[Tailhook]

SystemType=ARRESTER_HOOK

MaxDeflection=30

Retractable=TRUE

DeployTime=1.0

AnimationID=5

ModelNodeName=TailHook

AttachmentPosition=-0.0,-2.3164,-0.3915

HookArmLength=1.52

 

[WingFold]

SystemType=ANIMATION

InputName=ANIMATION_9

DeploymentMethod=MANUAL

AnimationTime=6.0

AnimationID=9

Share this post


Link to post
Share on other sites

right...airbrakes,fold and hook ok..

just cannot get the outer pylons to load at correct point.

unlinked them,reset xform and relink back to outerwing and double checked points and loaded up...still doing this..top pic

also now the shock anim is going loopy,starts off off ground a tad then as soon starts to roll...the shocks come down...if cant fix that will just disable.thing is its stock settings from original C version data.ini.

btw.

outerwing is connected to fold mech then thats linked to main wing.

post-1981-0-12336300-1357274559_thumb.jpg

post-1981-0-49186000-1357274621_thumb.jpg

Edited by russouk2004

Share this post


Link to post
Share on other sites

Russ,

 

On that weapons station, are you using both of the following entries?

 

MovingPylon=TRUE

RotatingPylon=TRUE

Share this post


Link to post
Share on other sites

yes m8

just 2 of the offending pylons

 

[LeftOuterWingStation4]

SystemType=WEAPON_STATION

StationID=24

StationGroupID=4

StationType=EXTERNAL

AttachmentPosition=-3.802,-3.132,-0.2

AttachmentAngles=0.0,0.0,0.0

LoadLimit=1550

AllowedWeaponClass=AHM

AttachmentType=WP

ModelNodeName=LeftOuterPyl

LaunchRailNodeName=

PylonMass=72.58

PylondragArea=0.02

FuelTankName=

SpecificStationCode=AA12

MovingPylon=True

RotatingPylon=True

 

[RightOuterWingStation4]

SystemType=WEAPON_STATION

StationID=25

StationGroupID=4

StationType=EXTERNAL

AttachmentPosition= 3.802,-3.132,-0.2

AttachmentAngles=0.0,0.0,0.0

LoadLimit=1550

AllowedWeaponClass=AHM

AttachmentType=WP

ModelNodeName=RightOuterPyl

LaunchRailNodeName=

PylonMass=72.58

PylondragArea=0.02

FuelTankName=

SpecificStationCode=AA12

MovingPylon=True

RotatingPylon=True

Share this post


Link to post
Share on other sites

Russ I would try in Max disconnecting that Pylon do a reset and adjust pivot..Then use the point to measure where the attachment should go again. Make sure you measure it in the closed position.

Share this post


Link to post
Share on other sites

right...got irms now in right place in Z axis...outerwings were off do had to reset xform them...still points dont tally...pylons are correct size as i reset them b4...im gonna have to keep moving attach points manually till they line up...veryyyyyyy od why folding wings porks the points up ? odd indeed

done some correct pylons too...more detail...got to skin em.(last pic)

also there was shad issue on the front wheel rear (green) guard(double faces) fixed that

post-1981-0-19009100-1357401062_thumb.jpg

post-1981-0-81462000-1357401070_thumb.jpg

post-1981-0-79931500-1357401092_thumb.jpg

Edited by russouk2004

Share this post


Link to post
Share on other sites

Russ, remove the wingfold animation entry in the data.ini, put the weapons where you think they should go.

 

If that fixes the problem visually, then having the animation for the wing fold being user controlled is the problem...and there is no solution.

 

FC

Share this post


Link to post
Share on other sites

yes m8 indeed....hadf same prob with the corsair for kevin...had to move points quite a way off from where they should go.

gonna post at 3rdwire and see if I get answer lol..wont hold my breathe.

tried with no wingfold and weapons show correct....weird..

also dont need this in data as its for sweep and doesnt affect folding wings such as this model.

oh well its trial and error time to sort the attachment points.as I did for the F4 corsairs

Edited by russouk2004

Share this post


Link to post
Share on other sites

i'm beginning to wonder if something in the latest patching hasnt hosed some of 'what worked before'. Been seeing a LOT of odd behaviours

Share this post


Link to post
Share on other sites

I keep trying to tell folks...USER CONTROLLED (manual) animations not tied to things like flight controls, hooks, wing sweep, landing gear, etc, have, as far as I know, NEVER worked with weapons hanging off the mesh in question. The code for pure user control wasn't even in the original game, and was added after people wanted to control the canopy opening manually.

 

FC

 

PS Hmmmm...now I'm not so sure...I tried with the F-111 in the Oct 08 version of WOE, and the weapons mounted fine. However, I could swear we had problems with the Super Hornet for SF1 and so didn't end up using it...

Share this post


Link to post
Share on other sites

I keep trying to tell folks...USER CONTROLLED (manual) animations not tied to things like flight controls, hooks, wing sweep, landing gear, etc, have, as far as I know, NEVER worked with weapons hanging off the mesh in question.

 

Wanna bet? :biggrin:

 

 

Edited by Fubar512

Share this post


Link to post
Share on other sites
Wanna bet?

 

Maybe. The SF1 version of the Super Hornet has roughly the same issue Russ is seeing on the MiG-29K.

 

Yet, the F-111E has no such problem.

 

Ed, what I need is an aircraft that the wing rotates in the Y axis, and the weapon stays in the same relative location...AND the weapon rotates properly. For instance, it took a while for us to notice the missile was not rotating. Because it was staying in the same proper location (on the wingtip).

 

Russ, try the entry like before (with the user controlled animation), but comment out the RotatingPylon=TRUE line. See if the missile at least mounts properly.

 

FC

Share this post


Link to post
Share on other sites

Damn it...too slow.

 

Okay, I see it...yep, that looks correct.

 

Well, hell...now I'm stumped.

 

Ed, can you send me the latest data.ini and I'll see if there is something I'm missing.

 

Actually, can you send the OUT file too?

 

FC

Share this post


Link to post
Share on other sites
Damn it...too slow.

 

Okay, I see it...yep, that looks correct.

 

Well, hell...now I'm stumped.

 

Ed, can you send me the latest data.ini and I'll see if there is something I'm missing.

 

Actually, can you send the OUT file too?

 

FC

 

that for su-33 ? if so can I take a look too plz

 

what ive got...< = direction of heirachy

Parent : leftwing<wingfoldright (which is actually leftouterwing end mesh)<leftouterwing... animated the wingfold then

im wondering if I should link as so.

Parent : LW<LOW<WFold

ps I did comment out the rotate pylon as its not actually rotating,,,thats for swept wings..and has no effct either way I did it

Edited by russouk2004

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..