Jump to content
Sign in to follow this  
citizen67

Is there a way to solve this issue?

Recommended Posts


It's not a real issue, I've seen worse on other terrains where it is due to wrong Tag value for the tile in the TFD. Can be fixed with TFDtool. Just live with it.

  • Like 2

Share this post


Link to post
Share on other sites

Drop the fuel tanks ! that's heavy load

and check the tyres pressure at the next station.
more seriously ->
If you start to edit the rolling radius of the wheels, do it with an unloaded plane at minimum fuel level.
Or then it will "float above the ground" when not loaded.

I tend to use a lowered value for the rolling radius of the wheels to have the visual effect of a slight squashing. Like every real tire, it increases the surface in contact with the ground.
I see no issue at all, except it's not realistic seen like that. But it's nothing compared to planes sinking in the runway at touchdown...

and...

ShockStroke=
SpringFactor=
DampingFactor=

are also some values that can effect the way a plane stands on the ground.

Check everything or don't touch anything :wink:

As long as the rim is not touching the ground it's safe ! xD

Edited by Cliff7600
  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Cliff7600 said:

Drop the fuel tanks ! that's heavy load

and check the tyres pressure at the next station.

:biggrin:

More seriously: thanks everybody. I'll try out, now.

Share this post


Link to post
Share on other sites

Well, according to the 3D model (USMC_AV-8B-Plus_93)

[MainGears]
...
ShockStroke=0.16   // is the exact value of the animation, so I wouldn't change it.
...
RollingRadius=0.465    //  The radius value from the 3D model is 0.3275, so the data.ini file give the main gears already 0.275 meter bigger than they really are.

My two cents are : RollingRadius=0.32 and try to edit the "SpringFactor=" and "DampingFactor=" values to have the result you want.

And don't forget the LeftOutrigger and RightOutrigger values as well.

  • Like 1

Share this post


Link to post
Share on other sites

Okay, I take back what I said, it's not fun and there is an issue. Though it's a very inconspicuous one.

There is no way to solve the issue without creating another in the process.

The problem is there's only one animation AnimationID=7 for all parts of the landing gear : front wheel, main wheels, and left and right outriggers.
And each has a different length of displacement when you play the animation.

As I am a long time "screw up the 3D model by ini" supporter, I made some shock absorbers by data.ini.
But it totally ruined the scissors movement for each  landing gear leg.

Stationnary
SuspTest_1.thumb.JPG.647e6700110b37b859e8c84aca8b6d97.JPG

Hovering
SuspTest_2.thumb.JPG.cec6990bc6b4beca95706230f887e1fe.JPG

Engine shut OFF, back to the ground
SuspTest_3.thumb.JPG.7b0a1b0f45d368b6c309c5ced1c553b3.JPG

While rolling, taking off
SuspTest_4.thumb.JPG.60d6999be75f09855a9afd3afafac1c5.JPG

Engine shut OFF, slammed to the ground
SuspTest_5.thumb.JPG.80f6811fe914aef0108610c42095c497.JPG

and I don't know if it's worth the editing (?)

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
----------------------------------------------------------------------------------------------------- OFF TOPIC --------------------------------------------------------------------------------------------------------------------------------------------

The following part is off-topic, but that could be useful and BACK-UP YOUR FILES FIRST !

To make some nice vertical take-off :

Fuel lower than 100% and no loads in the loadout menu because it's too heavy

In the data.ini :

-----------------------------------

[AircraftData]
...
CGPosition=0.0,0.0,0.0

-----------------------------------

[Engine1]
...
ThrustPosition=-0.93,-0.99, 0.0

[Engine2]
...
ThrustPosition= 0.93,-0.99, 0.0

[Engine3]
...
ThrustPosition=-0.93, 0.99, 0.0

[Engine4]
...
ThrustPosition= 0.93, 0.99, 0.0

-----------------------------------

[RCSPitchU]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=PITCH_CONTROL 
ReverseInput=FALSE
MaxThrust=3000.0
ThrustAngles=0.0,-90.0,0.0 
ThrustPosition=0.00,5.79,-0.85
ThrottleRate=100.0 
MinThrustVectorInput=0.2

[RCSPitchD]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=PITCH_CONTROL 
ReverseInput=TRUE 
MaxThrust=3000.0
ThrustAngles=0.0,-90.0,0.0 
ThrustPosition=0.00,-7.0,0.32
ThrottleRate=100.0 
MinThrustVectorInput=0.2

[RCSYawR]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=YAW_CONTROL  
ReverseInput=FALSE 
MaxThrust=2600.0
ThrustAngles=-90.0,0.0,0.0 
ThrustPosition=0.00,-6.30,0.00
ThrottleRate=100.0 
MinThrustVectorInput=0.2

[RCSYawL]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=YAW_CONTROL  
ReverseInput=TRUE 
MaxThrust=2600.0
ThrustAngles=90.0,0.0,0.0 
ThrustPosition=0.00,-6.30,0.00
ThrottleRate=100.0 
MinThrustVectorInput=0.2

[RCSRollR]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=ROLL_CONTROL 
ReverseInput=TRUE
MaxThrust=2600.0 
ThrustAngles=0.0,90.0,0.0
ThrustPosition=4.65,-2.2,-0.32
ThrottleRate=100.0 
MinThrustVectorInput=0.2

[RCSRollL]
SystemType=REACTION_CONTROL_SYSTEM 
InputName=ROLL_CONTROL 
ReverseInput=FALSE
MaxThrust=2600.0 
ThrustAngles=0.0,90.0,0.0
ThrustPosition=-4.65,-2.2,-0.32
ThrottleRate=100.0 
MinThrustVectorInput=0.2

-----------------------------------

[SeatEject]
ParentComponentName=Fuselage
ModelNodeName=SJU-4A
...
MassFraction=0.014    //maybe why not, or MassFraction=0.0

 

[R-R_Engine]
ParentComponentName=Fuselage
ModelNodeName=Rolsc-Royce
...
MassFraction=0.265

 

[Hide1]
ParentComponentName=Fuselage
ModelNodeName=SJU-4-1
...
MassFraction=0.0

 

[Hide2]
ParentComponentName=Fuselage
ModelNodeName=Seat01
...
MassFraction=0.0

 

[Hide3]
ParentComponentName=Fuselage
ModelNodeName=seatbelts01
...
MassFraction=0.0

 

[Hide4]
ParentComponentName=Fuselage
ModelNodeName=seatbelts2
...
MassFraction=0.0

-----------------------------------

In the cockpit.ini file :

Position=0.0,3.51,0.55

to give back the 0.16 meter taken from the CG value because the cockpit position is right on spot.

-----------------------------------

and I would say the [Engine5] would need some editing too but maybe it's not that important.

Think twice before editing anything :wink:

Edited by Cliff7600
  • Like 2

Share this post


Link to post
Share on other sites

there's a LOT of stock 3W aircraft with 'flat tires' too (the Phantoms come to mind). They all seem to work fine. As someone that's also done the LG editing, and really fouled things up, sometimes its just not worth it!! 

seems to fall into the 'better left un-messed with' category!! :)

  • Like 4

Share this post


Link to post
Share on other sites

Well, you all are convincing me to enter in the " better left un-messed with" world...

Share this post


Link to post
Share on other sites

The to-do list is looong for this bird (ini files)
Though it's fun. And maybe one day it will be totally messed-up xD

The stock harrier is working much better (after very few ini edits...).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..