Jump to content
Sign in to follow this  
squid

My SF2 won't start

Recommended Posts


It sound a lot like you are running an exe that was not properly updated with a patch. I have a similar issue with my "custom" exes when I do an update. I need to make sure I recreate the custom exes from a new patched exe to get any of them to work.

 

What is the name of the EXE file you are trying to start?

Share this post


Link to post
Share on other sites

Thanks everyone for the input.

 

- I updated to august 2011. No change

- The exes are :

  • StrikeFighters2.exe
  • StrikeFighters2 Vietnam.exe
  • StrikeFighters2 Israel.exe
  • StrikeFighters2 Europe.exe
  • StrikeFighters2 Exp2.exe

They are all now dated as 8.17.2011

 

(actually i am bit confused by the existence of separate exe (and folders) for the Exp2. Why is that?)

Edited by squid

Share this post


Link to post
Share on other sites

tried the administrator privilege, no change

 

make sure no programs are asking for permission for the EXE (ie Firewall, windows etc), it would leave you at a black screen, you'd have to ALT TAB and look for the prompt, grant access/allow, then restart the game.

Share this post


Link to post
Share on other sites

i am seeing in C:\Users\User\Documents\ a "Thirdwire" folder with "StrikeFighters2 Europe" and StrikeFighters2 Exp2" folders in it. Is that normal ?

Share this post


Link to post
Share on other sites

i am seeing in C:\Users\User\Documents\ a "Thirdwire" folder with "StrikeFighters2 Europe" and StrikeFighters2 Exp2" folders in it. Is that normal ?

 

 

Thats not the default location for the mod folders in Vista/7

 

Are they mod folders or is that where you have installed the core game folders to?

Share this post


Link to post
Share on other sites

i haven't installed in there anything. Also, the proper thirdwire folders (all of them) are in "Saved Games" as well (all the merge folders). (my mod folders are in a custom location "E:\GAMES\Thirdwire\Mods\" and installation folder in "E:\GAMES\Strike Fighters 2\")

Share this post


Link to post
Share on other sites

Check your opions.ini is pointing to your custom location. I had a similar problem as my OS is installed on an SSD and all games in a high speed mechanical.

Share this post


Link to post
Share on other sites

Ok heres a fix for modded installs that wont work after the update

 

delete the old exe you used for the modded exe,copy the SF2 exe,rename to whatever,then go to the options.ini in both folders,in (heres mine in win7 for example) C:\Users\Iron Maiden\Saved Games\ThirdWire\SF2-Modded

in normal SF2 folder in above location.

Open options.ini,scroll to the bottom and make sure the path is to your mod folder.

as below

 

[Mods]

ModsEnabled=TRUE

Directory=C:\Users\Iron Maiden\Saved Games\ThirdWire\SF2-Modded

Editors=StrikeFighters2

 

[screenShots]

Directory=C:\Users\Iron Maiden\Saved Games\ThirdWire\SF2-Modded\ScreenShots

Format=JPG

 

then just create new shortcut via the newly created exe.

Edited by russouk2004

Share this post


Link to post
Share on other sites

ermmm can you elaborate maybe bit more ?

- i have only updated exes.

- "old exe" = ?

- "modded exe" = ?

- which exactly i am copying? and what i do with the copy ? what i am doing with the original ?

- "both folders" = ? which one is the other folder ?

- "newly created exe" = how is this created ?

Share this post


Link to post
Share on other sites

Right

as you may know,you copy the original sf2.exe and the copy when executed,becomes your modded game,created in users\saved game folder path ok?.original folder and the new mod folder.

so you just need to delete the mod exe,then copy the newly updated exe,rename it to whatever you call your modded exe.

Share this post


Link to post
Share on other sites

the thing is, that i haven't created separate exes for my mods :( I have only created custom mod folders and modified the original options.inis to point there ....

Share this post


Link to post
Share on other sites

hmmm i have to check that. Self installed mods? ... i can't remember making any change since the last time it was working normally ... maybe installed the may update and didnt check right away if everything still worked ok? :boredom:

Share this post


Link to post
Share on other sites

I would do it like this:

 

- Download all SF2 Games (and expansions) I have from Thirdwire

- Backup my mods folder

- uninstall your SF2 installs (all)

- Install the new downloadet Games (no patching needet) in the order as shown:

1: SF2

2: SF2V

3: SF2E

4: SF2I

5: SF2 exp 1

6: SF2 exp 2

 

- Try to run all the Games. If they won´t run there must be something wrong with your system.

- If ok, install my mods again and try to run the sims.

Edited by Soulfreak

Share this post


Link to post
Share on other sites

The mod folders use a copied original exe,and these are NOT modified by updates,you MUST delet them and copy the newly updated original exe for it to work,as ive said 3 times now

Share this post


Link to post
Share on other sites

there are no .exe files in my mod folders (or in User\Saved Games\ folder) .... (never were)

Share this post


Link to post
Share on other sites

jeeezzz....

 

see pic below for an example of exes located in your C:\Program Files (x86)\ThirdWire\Strike Fighters 2

 

note that the dates of all additional exes (NOT the stock 3W one for main games and expansion paks) all match the date of the updated SF2.exe

 

we can't make it any simpler than this...

Share this post


Link to post
Share on other sites

I have never used separate (copies of originals) executables for mods . (Is this advised for some reason ?) k? ...

post-406-0-28909400-1314211696.jpg

Edited by squid

Share this post


Link to post
Share on other sites

the thing is, that i haven't created separate exes for my mods :( I have only created custom mod folders and modified the original options.inis to point there ....

 

and if i restore the options.ini mod folder lines to point to the default location and / or put FALSE to the mods enabled line, nothing changes

Edited by squid

Share this post


Link to post
Share on other sites

Again, did you download anything for SF2 from another site? PM me if you don't understand the question.

Share this post


Link to post
Share on other sites
Is this advised for some reason

 

ah... yauh!! Something called "era and region specific installs". A highly reccomended thing to do

 

---------

the elephant in the room that Fub's is trying to skirt, is that another member downloaded the Flatapus (Flanker)

from the Insky site and got hit with a supremly nasty virus.

 

this is the question he's asking == have you downloaded anything from them? Have you scanned -DEEP scan- for infections? Or are you installs just screwed up??

 

edit: looking at your screenie, your MAIN installs are all f***ed up .. they should be in the C:\Program Files (x86)\ThirdWire\Strike Fighters 2

 

this is WHERE they want to be .. and SHOULD be.

 

If it were me, I'd delete EVERYTHING and start factory-fresh install the way it was designed to be

Edited by Wrench

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..