Jump to content

Recommended Posts

Hi all gents.

I know that this topic was discussed in the past,but I'll finally change my PC,switching from Win 7 to 10. I remember that some users have had trouble running 3W sims, so before starting all I will know any possible advice.

 

Thanks for the help

Share this post


Link to post
Share on other sites

Hello RustyKurnass,

I have been running the game for over a year now using windows 10 and I have no problem with it so far.

 

Share this post


Link to post
Share on other sites

The only major problem I've had running SF2 in Win 10 has been with my Nvidia graphics card drivers.

Updated drivers cause the game to go black when starting a mission if the game's graphics settings are set to 'unlimited.'  It works fine on 'high' graphic setting.

The 'fix' for me has been to keep an old set of drivers installed so I can run the game on 'unlimited' setting.

If you don't use a Nvidia graphics card you might not have this problem.

  • Thanks 2

Share this post


Link to post
Share on other sites
4 minutes ago, Geary said:

Updated drivers cause the game to go black when starting a mission if the game's graphics settings are set to 'unlimited.'  It works fine on 'high' graphic setting.

To be more precise, the issue is due to the Effects setting. Effects should be set to High, everything else can be set to Unlimited, AFAIK. As I stated countless times, with Effects set to Unlimited, the game uses specific DirectX 10 calls which have been implemented poorly, I guess.

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites

Also, it doesn't hurt to run SF2 (and FE2) in Win7 compatibility mode too - on Win10. I run them that way and I've had no CTDs at all. Same advice applies to the OBD sims (WOFF/WOTR), as well as IL2-1946.** For ROF I haven't noticed any benefits to running in Win7 comp. mode.

**For IL2-1946, don't forget also to enable "DEP protection" only for essential programs (in the relevant setting in the control panels, "system"), otherwise it doesn't load on Win10.

Happy flying,

Von S :smile:

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I have found "windows 7" compatibility is needed because if I don't do it then mods don't work eg loading screen, main screen and music. Perhaps more don't work but I don't know because each time it happened I went out and immediately made it compatible.

Ah it was effects was the issue. I only had got as far as narrowing it down to effects, shadows or water, cool:smile:
 

Share this post


Link to post
Share on other sites

Thanks for the advice guys!

Effectively what worried me is possible problems to run the variouus mods, but for this I'll wait 'till next week when the PC will be ready.

I'm thinking if split the 2nd SSD and add a Windows 7 copy to run the games will help...

Share this post


Link to post
Share on other sites

Ok guys,my fear is true.

A pair of days ago I bought my new PC with Win 10.I've reinstalled all the SF2 titles and all merged and upgraded to July 2013 + all the DLC.

At this point I installed the Desert Storm mod following all the instructions,as if it was the first time and nothing...

Any ideas?

Share this post


Link to post
Share on other sites
1 hour ago, RustyKurnass said:

Ok guys,my fear is true.

A pair of days ago I bought my new PC with Win 10.I've reinstalled all the SF2 titles and all merged and upgraded to July 2013 + all the DLC.

At this point I installed the Desert Storm mod following all the instructions,as if it was the first time and nothing...

Any ideas?

did you run windows compatibility? if you did please run Compatibility Troubleshooter and select the falling

20200210_231630.png.68a5ddee8a647205fd86f08aa4c19c78.png

and for windows select earlier versions windows 7 service pack 2.

Edited by GKABS
  • Like 1

Share this post


Link to post
Share on other sites

To be more correct,the "vanilla" 3rdW games start without problem,when I try to run the ODS mod, what start is the basic SF2 game, with all the stock Campaign and DLCs.

I started to think seriously to the dual boot...

Share this post


Link to post
Share on other sites

Rusty,

  Once you've created a vanilla install for ODS, it starts up with the generic game.

  You must 'clean out' planes, etc. you don't want in your ODS install and place the ODS files into the generic game folder you created for your ODS install.

  Don't know if I'm making sense or not...

Share this post


Link to post
Share on other sites

Thanks Geary,this's what I've done.

After copy an .exe ( SF2NA),I started and closet it to create the appropriate ODS folder in Saved Games. Here, I cleaned all the Object subcategory and added the files from the three zipped folder downloaded,made the option.ini correction and...nothing,when start the exe I've a normal SF2 screen running.

I tried twice the re-installation of the modded campaign and nothing.

I'm a noob ok, but in m the old Pc Win7 I added at least 4 complet modded campaign + a lot of skins,planes,etc...and all running (almost) smoothly.

Start to thing more and more at the dual boot option

Share this post


Link to post
Share on other sites

It can be cause by another program running in the background especially security software.

Try turning off all Games bar in the Games mode settings the WIn 10 settings

right click on the shortcut or exe and click "disable full screen optimisations", also try "Run this program as administrator"

Also I don't install any games under program files these days - are all on another drive - not sure if this matters anymore

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the info, i've already try to run the game as administrator and nothing.

I think that I'll install Win 7 on the second SSD ( actually totally untouched) and run all from here as  dual boot. Maybe this will preserve me from future headeches

Share this post


Link to post
Share on other sites

Sorry guys for the stuoid question,but today I retired the new PC and tomorrow will install all the SF" games;the question is ,as my games are all updated at July 2013,I need to install TW patches or not?

Share this post


Link to post
Share on other sites

No, the last patch was July 2013 so you'll be good when you reinstall. Even the SF2 Complete is at Jul 2013

Edited by EricJ
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..