Jump to content

Recommended Posts

This thread is to be a summary of all we know about Naval Warfare in SF2 Campaigns.

 

First of all; this post by Wrench is very important.

 

you're gonna make me look for it, aren't you JR??? :lol:

 

well, I can't find it either! I know pureblue wrote the post!

 

what you need to do, is have the water bmp, and add in the areas, like below (pureblue did this one for me for the Persian Gulf -- it actually needs another in the Arabian Sea, to the east, and several small 'enemy' surface action group stations in the straits of hormuz, near busher and in the middle near kish island)

 

anyway, you see the color swatches on the left? the dark green is for friendly, the pukey light green is enemy. Taken from the example seen on the IcelandNA_water.bmp

 

now, how the enemy station will work for an enemy withOUT carriers, I don't think we've figured out yet. (in this case, the Iranians only have firgates, destroyers, FABs, etc)

 

After that, you need to make your map is a NavalMap. Simply add NavalMap=TRUE into your Terrain ini file. Same for the Campaign. It must be NavalCampaign=TRUE. Add this to both the Campaign ini and Campaign Data files.

 

The format for Task Forces is as following:

 

[NavalUnit001]

UnitName=Chuck Norris

ForceID=1

Nation=USN

RandomChance=100

MaxObjects=7

Experience=100

Morale=100

Supply=100

Intelligence=0

StartPosition=225000.0,212000.0

ObjectivePosition=560000.0,380000.0

HomePortPosition=0.0,200000.0

Ship[01].Type=CVN-68

Ship[01].Name=USS f***ING AWESOME

Ship[01].Number=78

Ship[01].Texture=USNGrey1

 

They require their own part; under naval units.

 

Relevant missions for anti-ship is:

 

MissionChance[NAVAL_SEARCH]=

MissionChance[NAVAL_ATTACK]=

MissionChance[ESCORT_JAMMER]=

MissionChance[ESCORT_DECOY]=

MissionChance[CRUISE_MISSILE]=

MissionChance[EARLY_WARNING]=

 

It is yet not clear if this can be mixed between Naval / Land strikes. Considering the A-7 in the NA Campaign is prone to engage ground targets, I would say they are meant to be mixed. I suppose we have to wait for the patch until we know for certain.

 

Add your own experiences here; contradict me if you feel its appropriate and always work to improve :drinks:

 

 

I am currently working to adding Task Forces in TSF. Naval Search is Flyable; but lacks mission text that tells you what to do. If anybody knows how to add such text, I would love to know. Also, the enemy task forces are usually just a single vessel.

Edited by JonathanRL

Share this post


Link to post
Share on other sites

The Intelligence command is incredibly important to trigger Naval Strikes.

 

Just to see what happened, I put it onto 100. I had a ground battle; with air support and naval strikes by BOTH SIDES happening at the same time. If set to lower, your side may require to gather more information before they know where they are; before commiting to air strikes.

 

I still only can get a single ship per Task Force to appear; but that is of less concern at the moment.

 

My own Naval Strike however targeted a point inland where there was nothing to attack.

 

Screenshots:

 

post-14846-0-36333600-1332238164.jpg

 

post-14846-0-32856700-1332238172.jpg

 

post-14846-0-00348100-1332238193.jpg

Share this post


Link to post
Share on other sites

Is there a way to have ship vs ship combat?

 

For Ship vs Ship Combat to happen with Task Forces, we probably need them heading on a course towards eachother and with dedicated anti-ship weapons (Anti-Ground).

But that is a guess. In Theory, there is nothing that says it cannot be done.

Share this post


Link to post
Share on other sites

Is there a way to have ship vs ship combat?

 

Yes, they will engage one another with any weapons at their disposal. They will even engage well over the horizon, using cruise missiles or heavy-caliber guns.

  • Like 2

Share this post


Link to post
Share on other sites

Found some more interesting lines:

 

[CAP_NAVAL]

 

[iNTERCEPT_NAVAL]

 

[ESCORT_NAVAL]

 

[sTRIKE_NAVAL]

 

[sEAD_NAVAL]

 

Maybe Naval_Attack is simply outdated? EDIT:

Seems Busted. Strike_Naval triggers a recon flight; when Naval Attack triggered assault on a Task Force.

 

Same with CAP_NAVAL, INTERCEPT_NAVAL and ESCORT_NAVAL

Edited by JonathanRL

Share this post


Link to post
Share on other sites

Ok; I think I know why player Naval_Strike is busted; but it is only a guess.

[sEAD_NAVAL] works just fine, but it targets the escort ships. On my maps, There are only destroyers and frigates - escorts; so you are sent to engage the escorts. One simply has to tag the cargo vessels / Big ships as the priority targets.

 

post-14846-0-98022500-1332264680.jpg

 

 

post-14846-0-93221100-1332264701.jpg

Share this post


Link to post
Share on other sites

Reagarding fleets engaging each other, I've seen them fighting at a few miles guns only. Asideaside from lots of explosions not a lot seems to be happening... 15 minutes of them pounding away at each other scoring ht after hit and not a single ship was any worse for wear.... aside from my carrier which had fires on deck where the volley of SAMs trashed my flight 5 seconds after spawning :boredom:

 

Craig

Share this post


Link to post
Share on other sites

For the ships:

 

CollisionMesh=

&

WarshipClass=

Are important:

 

The first defines the way the ship takes damage. The second defines the class of the ship, positioning it in a formation in a task force.

 

CollisionMesh= has to be a LOD file, and it does not seem like using the same LOD file as for the 3D model works.

Edited by JonathanRL

Share this post


Link to post
Share on other sites

Jonathan, about your anti shipping post at TW, just did a test in stock NA terrain.

Inserted ANTI_SHIP to allowed missions for the terrain and also added a shipping line in movements.ini

As you noted, as flying for friendly side, I can't get a proper Anti_Ship mission. The game gives me a Hawkeye with a generic Recon route (2 waypoints) and a null target.

BUT if I fly the red side, I do get a proper mission. Just attacked a convoy of CargoShips at the shipping route I inserted below.

Something to investigate perhaps..

I think all this stuff is related to NavalMap=TRUE. And hope TK modifies this behaviour..

 

[Route009]

RouteType=SHIPPING

StartArea=Selfoss

EndArea=Vík í Mırdal

RoutePosition[001]=500000,200000

RoutePosition[002]=400000,200000

Edited by PureBlue

Share this post


Link to post
Share on other sites

I suggest you post that over at TKs forum; so he has a place to start.

I think all this stuff is related to NavalMap=TRUE

 

Maybe, but maybe not as I tried Dhimar/Paran map as well in my untouched installation.

 

Hopefully, he also adds my little other suggestion but at any rate; but it must be fixed.

Edited by JonathanRL

Share this post


Link to post
Share on other sites

Do we know what file determines the general make-up and formation of a naval group in single missions and what year they start showing up?

Share this post


Link to post
Share on other sites

i would guess the formations ini; which I haven't pulled to inspect yet....unless he's added it somewhere else!

Share this post


Link to post
Share on other sites

The Formations.INI file looks the same as before, I can't see anything in it about carrier task forces.

And these isn't a new NavalFormations.INI, or anything like it.

Share this post


Link to post
Share on other sites

Is there a trick to getting the decks of carriers populated? I have the task force working properly, but no planes occupying the decks.

Share this post


Link to post
Share on other sites

Is there a trick to getting the decks of carriers populated? I have the task force working properly, but no planes occupying the decks.

 

Yes, there is a required method

 

Check under the [Deck] entries in the carrier's DATA.INI...

 

The stock layouts are pretty much self-explanatory.

 

 

 

 

 

SidDogg

Share this post


Link to post
Share on other sites

Yes, there is a required method

 

Check under the [Deck] entries in the carrier's DATA.INI...

 

The stock layouts are pretty much self-explanatory.

 

Thanks, I did check that. I'm using all stock objects (CVA-63 and F-14A). Planes show up on deck in single player missions, but not during the campaign. Weird. Not a huge deal.

Share this post


Link to post
Share on other sites

Using the same .LOD works:

 

[GroundObjectData]

DamagedModel=

DestroyedModel=

DestroyedEffect=ShipDestroyedEffect

DamageEffect=ShipFireEffect

CollisionMesh=Cavalier.LOD

SystemDamageEffect=ShipSystemFireEffect

 

I used this; and the result was actually pretty nice. Not for the Swedish Navy tought! :D

Time to fix up the task forces; add torpedo bombers and wait for the proper patch.

 

post-14846-0-89678100-1332404828.jpg

Edited by JonathanRL

Share this post


Link to post
Share on other sites

Thanks, I did check that. I'm using all stock objects (CVA-63 and F-14A). Planes show up on deck in single player missions, but not during the campaign. Weird. Not a huge deal.

 

 

 

You're not alone, I am seeing exactly the same problem in both modded and bone stock installs. As I posted in the main SF2NA thread, the really weird thing is that if you save a campaign generated mission, and then fly it as a single mission, the decks are populated :dntknw:

Share this post


Link to post
Share on other sites

Thanks, I did check that. I'm using all stock objects (CVA-63 and F-14A). Planes show up on deck in single player missions, but not during the campaign. Weird. Not a huge deal.

 

 

You're not alone, I am seeing exactly the same problem in both modded and bone stock installs. As I posted in the main SF2NA thread, the really weird thing is that if you save a campaign generated mission, and then fly it as a single mission, the decks are populated :dntknw:

 

I'm currently trying to revamp my modded Operation QuickSand campaign to March 2012 standard with mixed results. I updated the CAMPAIGN.INI and CAMPAIGN_DATA.INI files by closely comparing them with the SF2NA campaign files. Starting the campaign flying RAF or Mercenary is no problem - if I try to fly for the USN,USMC or USAF the game freezes as soon as I click on the "Accept" tab, meaning I have to shut the game down via the Task Manager.

Single missions from the carrier in the Desert - sorted. Created an updated DESERT_WATER.BMP file and all. It's just the campaigns have got me scratching my skull right now :dntknw:

Share this post


Link to post
Share on other sites

I'm currently trying to revamp my modded Operation QuickSand campaign to March 2012 standard with mixed results. I updated the CAMPAIGN.INI and CAMPAIGN_DATA.INI files by closely comparing them with the SF2NA campaign files. Starting the campaign flying RAF or Mercenary is no problem - if I try to fly for the USN,USMC or USAF the game freezes as soon as I click on the "Accept" tab, meaning I have to shut the game down via the Task Manager.

Single missions from the carrier in the Desert - sorted. Created an updated DESERT_WATER.BMP file and all. It's just the campaigns have got me scratching my skull right now :dntknw:

 

I was able to mod the stock 1975 campaign to allow the USN units to launch off a carrier with no issue. I didn't go beyond that (adding AEW or anything) because I wanted to see if it could be done, and it's pretty straightforward. When I get home from work I can attach my modified inis so you can compare against them. There's literally no changes beyond adding a carrier group - no additional planes or anything, aside from a few squadron changes for the F-14s.

 

I'm tempted to wait until a patch to see if it fixes the issues with carriers being populated. I've narrowed down a couple issues with the carriers that I'm seeing:

 

1. No decks are populated in campaigns, whether stock or modified. This is using both stock and modified aircraft (with the appropriate ini edits). I get appropriately populated decks in Single Player missions.

 

2. The jet blast deflectors on the CVA-63 and SCB-125 carriers work with no issues. The JBD on the stock CVN-68 does not raise.

 

EDIT: Attached campaign files.

 

CAMPAIGN5.zip

Edited by Shotgun 27

Share this post


Link to post
Share on other sites

I was able to mod the stock 1975 campaign to allow the USN units to launch off a carrier with no issue. I didn't go beyond that (adding AEW or anything) because I wanted to see if it could be done, and it's pretty straightforward. When I get home from work I can attach my modified inis so you can compare against them. There's literally no changes beyond adding a carrier group - no additional planes or anything, aside from a few squadron changes for the F-14s.

 

I'm tempted to wait until a patch to see if it fixes the issues with carriers being populated. I've narrowed down a couple issues with the carriers that I'm seeing:

 

1. No decks are populated in campaigns, whether stock or modified. This is using both stock and modified aircraft (with the appropriate ini edits). I get appropriately populated decks in Single Player missions.

 

2. The jet blast deflectors on the CVA-63 and SCB-125 carriers work with no issues. The JBD on the stock CVN-68 does not raise.

 

Here's my own if anyone wants to check them out as well:

CAMPAIGN3.rar

Mind you, I'm using my Desert3 terrain and I've added RAF squadrons. It may be a post-release "bug" that could be sorted with the next patch, but in any case if I have missed something, there's the files.

Share this post


Link to post
Share on other sites

Here's my own if anyone wants to check them out as well:

CAMPAIGN3.rar

Mind you, I'm using my Desert3 terrain and I've added RAF squadrons. It may be a post-release "bug" that could be sorted with the next patch, but in any case if I have missed something, there's the files.

 

Is it possible your campaign is crashing because some of the units have NAVALATTACK specified when you don't have an enemy CVBG specified? If the game has nothing for them to attack, would they not spawn, or try to spawn, attack something that isn't there, and crash?

 

EDIT: I added my campaign files to my previous post if you want to look at them.

Edited by Shotgun 27

Share this post


Link to post
Share on other sites

Is it possible your campaign is crashing because some of the units have NAVALATTACK specified when you don't have an enemy CVBG specified? If the game has nothing for them to attack, would they not spawn, or try to spawn, attack something that isn't there, and crash?

 

EDIT: I added my campaign files to my previous post if you want to look at them.

 

No that's not the problem. The campaign was freezing even when I tried to start flying for the USAF, which has no naval mission type prompts in the campaign_data.ini. Even before I added the prompts to the USN squadrons it was freezing.

Checking out your INIs now. Actually I just had an idea to try them out in my SF2 install. At least if they work for me then I'll know it'll probably be my campaign files.

Share this post


Link to post
Share on other sites

No that's not the problem. The campaign was freezing even when I tried to start flying for the USAF, which has no naval mission type prompts in the campaign_data.ini. Even before I added the prompts to the USN squadrons it was freezing.

Checking out your INIs now. Actually I just had an idea to try them out in my SF2 install. At least if they work for me then I'll know it'll probably be my campaign files.

 

You might want to use my watermap too.

 

desert_Water.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..