Jump to content
Wrench

Going back to an earlier patch level? How To?

Recommended Posts

ok, since the 7/13 patch fiasco (see "Well and Truly...." thread) started with trying to reinstall at an earlier patch level,

 

What is/are the procedures for doing so?

Does anyone have a step by step on this??

 

I'm making the assumption (oh! that word!!) that one would need to COMPLETLY uninstall ALL the SF2 exes, and start with new, unpatched installs, then patch to (whichever) level worked before??

 

More information in requested, and will be placed in the KB to (hopefully) prevent others from getting raped like I did.

Share this post


Link to post
Share on other sites

I think the only way is deleting the entire Thirdwire folder in the program folder, removing this way the patched cat-files and then re-install from the last working build, which was May 2013 I think.

The problem is to obtain those installers, since TK automatically updates them as well.

 

After installing, I think that faking to have the most up to date version would be the option. Inside the mod folder is the version.ini. I'm not sure but I think that it would work if you change the installed version build (let's say May 2013) to the most current build (e.g. July 2013). I imagine that by doing this, the game does not update. But it's only speculation.

 

Maybe anybody else has a better idea.

Edited by ValAstur

Share this post


Link to post
Share on other sites

I should have also mentioned, that I've archived the ORIGINIAL install exes, from the time of first release. I don't use the web-based installer, as well...bluntly put -- I can't (some games were gifts)

 

So, it's start from (original issuance date), then patch up accordingly. Sort of like what I did when I had the HD crash, and installed the new HD

Share this post


Link to post
Share on other sites

What did the Jul 13 patch do? My installs are running perfect. Yes they are heavily modded.

Share this post


Link to post
Share on other sites

Kevin, good that (at least) you have/kept all the original exe's - otherwise you would be lost... This way, it's "just" a lot of work re-installing and patching all the games...

 

What I also do, is keep copies of every game-install on a back-up-drive - deleting a "crashed" game and copying back from the back-up is well possible then...

 

As in several previous threads: BACK UP, guys - there will come a time, where you will say "good that I did"!

  • Like 1

Share this post


Link to post
Share on other sites

I keep the original exes from the date i got them. So i would unsintall, reinstall, and patch to the desired level with the patch archive in TWs page.

 

However, i have an stock install due to performance trouble with my current laptop, so i had no trouble with mods whatsoever (watching the mods going out is like an eunuch watching a playboy magazine) wich means i´m basically cool with the latest patch available in each moment.

Share this post


Link to post
Share on other sites

What did the Jul 13 patch do? My installs are running perfect. Yes they are heavily modded.

 

Guess you're lucky then because I'm having infrequent freezes when accessing the Loadout or Map menu, either during Campaign or Single missions. The fact that they are infrequent makes it even harder to grasp what's wrong with it. 

Edited by Gocad

Share this post


Link to post
Share on other sites

I had the same problem with the July patch randomly freezes, crashes to desktop, naval operations broken for my ATEAM WW2 installations ...

The key point will be to know the differences between Kevin and Dave installations.

Why Dave's heavily modded installs are running perfect, and mine, Kevin , Gocad randomly crashing ?

Share this post


Link to post
Share on other sites

I have Stary's effects and environmental mods; I am running Ravenclaws and my own weps packs. I have 418 aircraft installed. I am running North Cape, Desert 3, Green Hell, Stary's Germany and Israeli updates Persian Gulf, Black Sea, Formosa and DBS terrains. I am running SZ's speech mod and Home Fries Top Gun menu music.

Share this post


Link to post
Share on other sites

 

I have Stary's effects and environmental mods; I am running Ravenclaws and my own weps packs. I have 418 aircraft installed. I am running North Cape, Desert 3, Green Hell, Stary's Germany and Israeli updates Persian Gulf, Black Sea, Formosa and DBS terrains. I am running SZ's speech mod and Home Fries Top Gun menu music.

 

 

Ty for the quick reply did you have NATO5 Mod installed too ?

I have the same mods installed except Weapons packs a mix between NATO5 and Ravenclaws ones.

When I've tried to play a NATO5's campaign mission I crashed randomly, perhaps a problem with some ground objects install by the NATO5's mod ? I duno yet

Share this post


Link to post
Share on other sites

No I do not have NATO 5 installed.

Share this post


Link to post
Share on other sites

Well, if I got this correctly the cause for the crashes for the DAT PTO carrier mission has been found by Charles, it seemed to be an issue with some effects files. But since I don't even have that mod it's unlikely that this is causing my problems here. Not to mention that I don't have any inflight issues as far as I can tell, it's just the menu windows were I run into trouble, but since it's intermittent it's kinda hard to say with what exactly.

 

On top of that it's also fair to assume that no installation is like the other here...and mine is a mess really. :blink:

 

It would be huge step forward though if it were possible to reproduce these freezes, because I have none of the issues Piecemeal has...

 

EDIT:

 

TK has released a hotfix....flown a few campaign missions....no issues with the Loadout or Map menu,

 

http://www.thirdwire.net/files/dl/SF2_Jul2013_Hotfix.exe

Edited by Gocad
  • Like 1

Share this post


Link to post
Share on other sites

I bit the bullet and did fresh install to july2013 and game seems fine now...even with older level patch a\c and old data.ini`s etc.


Kev...do install to july2012,copy folder...update copy folder...add dlc...then start the copy games once...then all I did was copy over dlc,and may2013 dlc to july2012 level and they all show up ok.then del copy(may\july2013 copy folder)deleting the july2013 cats hasnt seemed to cause me any probs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..