Jump to content
Sign in to follow this  
Dave

The "Things You Need to Update Thread"

Recommended Posts

Post your fix/update findings here. Not whats broken, only a fix and or update. Everything else will be deleted by Lazer Cats

 

 

Aircraft with avionics70 need to have the radar ground mapping mode called GM in avionics.ini

And also, later in the avionics.ini you need to have

 

[RadarDisplayGM] and not

 

[RadarDisplayGround_Map]

 

In the ***_Avionics.ini, all you need to is change the spelling from "GROUND_MAP" to "GM" in the modes line, scroll down to the affected section, change it to "GM", do a quick repaint of the "F16_radarAB.bmp" to cover the "NOT WORKING", and zingoo!!!! Ground radar for you Viper!

 

This is all in WoE, btw.

 

Discovered by Canadair and Wrench, The

 

These bmp's go into the cockpit folder of the MF Vipers or any viper that uses a MF pit.

Attached File(s) winrar.gif radarbmp.rar ( 2.97K ) Number of downloads: 0

Share this post


Link to post
Share on other sites

Found this fix over at the A-Teams site, fixed my AI Skyraiders problems with taxiing in WOV.

 

In the data file for each plane scroll down to tail gear.

 

Maxsteering angle should be a positive number not negative

 

for example 50 not -50

 

Cheers

Snapper 21

Share this post


Link to post
Share on other sites

In case someone thinks the TV and Laser designator screens do not work, well they need to be airborne (higher that 30 ft or somethin,, althoguh I tried keeping the maverick selected during the approach and it was on all the way..)

AND

you need in the avioncs file the [TVdisplaydata] and the [Dtvfilter or somethinglike that] entries

Edited by Canadair

Share this post


Link to post
Share on other sites

When putting older A/C into wov/woe from my previous install I have opened the xxx.ini (eg f-16a.ini) and changed the shadow code to this:

 

[shadow]

CastShadow=TRUE

ShadowCastDist=10000

MaxVisibleDistance=800

Share this post


Link to post
Share on other sites

Noticed in the WOE 1979 default campaign -

 

in WOECAMP2_data.ini the F-4E squadrons have a typo:

 

//----- Player Unit

[AirUnit017]

AircraftType=F-4E

Squadron=313TFS

ForceID=1

Nation=USAF

DefaultTexture=USAFCamo2 <------meant to be USAFGreen1

 

 

 

Whether it cause any issues - I dont know because ive fixed it before playing.

Share this post


Link to post
Share on other sites
When putting older A/C into wov/woe from my previous install I have opened the xxx.ini (eg f-16a.ini) and changed the shadow code to this:

 

[shadow]

CastShadow=TRUE

ShadowCastDist=10000

MaxVisibleDistance=800

 

Does that give precalculated shadows to all a/cs?

Share this post


Link to post
Share on other sites

For those inclined to make their own ObjectData.cat...you can delete ALL .SHD files. The game doesn't need them. I've been flying several missions without them and the game engine works just fine making shadows on the 'fly'...so to speak.

 

FastCargo

Share this post


Link to post
Share on other sites

In the same vien as the F-16 A-G radar fix, here's one for the F-15E Mud Hen.

 

=NOTE THIS IS FOR WOV and WOE ONLY. WoI uses a different naming convention, and is mentioned at the end.

 

Now, I'm sure it might not be the correct 'display', but I used the F-4E_radarPPI.bmp, which exists in all versions of the game. (even though there IS an F-15radar_ppi.bmp already in the cockpit folder -- you choose which you like best)

 

SO, open you F-15E_AVIONICS.INI, and add the following line to the [Texture] section at the top:

 

RadarAGTexture=cockpit\f-4e_radarPPI.bmp

 

Scroll down a little furthere, to the "AvailableModes=" line and it should read like this:

 

AvailableModes=SEARCH,TWS,STT,ACM,TV,GM

 

(remember, WoE and WoV use the "GM" tag for the air-ground radar)

 

Copy/paste the data below into the avionics.ini; I just stuck it after the [RadarDisplayACM], which seems like a logical place

 

[RadarDisplayGM]

RangeSetting=2,3,4

PPI=TRUE

MapBackgroundLevel=0.2

MapHighlightLevel=0.6

ScanRate=140

ScanBeamAngle=2.5

ScanArc=60

GroundSearchStrength=50

Symbol[01]=HorizonLine

Symbol[02]=RangeScaleText

Symbol[03]=ElevationCaret

Symbol[04]=AzimuthCaret

Symbol[05]=TargetPDT

Symbol[06]=TargetTAS

Symbol[07]=TargetAspect

Symbol[08]=TargetHeading

Symbol[09]=TargetRangeCaret

Symbol[10]=TargetAltitude

Symbol[11]=TargetClosure

 

Save and close.

 

 

For WoI, you'd use it's naming convention, GM is replaced by "GROUND_MAP". So where it's says GM, use GROUND_MAP. Other than that, it should be the same. (in other words, I forgot to test in WoI!!!)

 

And there you are! Now, if I can figure out the Terrain Avoidence mode....

Share this post


Link to post
Share on other sites
Noticed in the WOE 1979 default campaign -

 

in WOECAMP2_data.ini the F-4E squadrons have a typo:

 

//----- Player Unit

[AirUnit017]

AircraftType=F-4E

Squadron=313TFS

ForceID=1

Nation=USAF

DefaultTexture=USAFCamo2 <------meant to be USAFGreen1

 

 

 

Whether it cause any issues - I dont know because ive fixed it before playing.

 

Are you seeing this post patch? I noticed and corrected the issue with the previous patch, but when I extraced the campaign data.ini after the latest patch, I found the correct texture listed (USAFGreen1).

 

Then to make matters more interesting, even with the correct texture listed in the campaign data.ini, the aircraft was still defaulting to SEA camo...?

 

Anyone had similar issues?

Share this post


Link to post
Share on other sites
Are you seeing this post patch? I noticed and corrected the issue with the previous patch, but when I extraced the campaign data.ini after the latest patch, I found the correct texture listed (USAFGreen1).

 

Then to make matters more interesting, even with the correct texture listed in the campaign data.ini, the aircraft was still defaulting to SEA camo...?

 

Anyone had similar issues?

 

Yes - I have just extracted WOECAMP2_data.ini from my Sept2008 version which was installed from scratch to check - every F-4E unit is listed with DefaultTexture=USAFCamo2

Share this post


Link to post
Share on other sites

Thanks for the Vipers fix, now my A falcons are set and good to go.

 

Qestion: Anyone published avionics70s.dll updates for the B/C/D Vipers?

If no, then i will have to rob the one from the ADF viper.

 

Second: Any avionics70s.dll updates for the eagles out there? Wrench got me thinking mentioning the E but mine is set to 60s.dll so no joy there.

 

S!

Share this post


Link to post
Share on other sites

There's been some issues with shadows as well, mostly discussed in the "Official Patch Thread", but I'd like to add something to the mix.

 

I was noticing in my "all is everything install" (fully patched, via the copy/paste of the updated exes, dlls and cats as per the KB -which, as we will see, does NOT fully update aircraft inis, skins and decal inis), that the Fresco I'd just shot full of holes ... wasn't holey!! Now, the Sept patch added the new damage bmps and tgas that are stored in the objects cat, as first seen in WoI. Also, the Game Engine ™ generates shadows differently; probably off the aircraft's main LOD itself.

 

So, looking in the clean install, I noticed this entry in the stock aircratf's main ini:

 

[DamageTexture]

DamagedPostFix=_holes.tga

 

[shadow]

CastShadow=TRUE

ShadowCastDist=10000

MaxVisibleDistance=800

 

So, being the expermential kinda guy I am, I tested out adding these entries in place of, or over, existing shadow/damage entries for the myriad variants of the Fresco, Farmer and Fishbed that exist in this "all is everything" install (PLAAF, Indian, Paki, whoever/whenever/wherever).

 

And all the shadows came back, as did the very cool new damage 'effect' to the aircraft model.

 

By the way, this can be added to 3rd party aircraft as well; in particular I tested it on Wolf257s P/F-51D-30 and Pasko's Vampire, both of which had odd shadow effects.. .. they look almost normal now.

 

So, just copy/paste that data above in the ini, and you should be good to go.

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites

I finally found a real fix to that TMF F1-C and Super-étendard canopy opening and wing folding problem:

 

 

 

 

Go to the plane data.ini, open it and tape edition/search for "animation". You 'll arrive there ( this is the super étendard) :

 

 

[Canopy]

SystemType=HIGHLIFT_DEVICE

DeploymentMethod=AUTOMATIC_SPEED

ModelNodeName=Main_Canopy

Setting[1].Angle=45.00

Setting[1].DeployValue=5.0 ---------------------> Those values just need to be inverted!! I guess the patch made them opposite.

Setting[1].RetractValue=3.0 ---------------------> The retract value must be higher than deploy value.

MaxDeflection=45.0

MinDeflection=0.0

ControlRate=0.3

AnimationID=9

 

So after correction it should look like this:

 

Setting[1].DeployValue=3.0

Setting[1].RetractValue=5.0

 

[WingFold]

SystemType=HIGHLIFT_DEVICE

DeploymentMethod=AUTOMATIC_SPEED

Setting[1].Angle=60.0

Setting[1].DeployValue=3.0 ----------------------> And same here

Setting[1].RetractValue=1.0

MaxDeflection=60.0

MinDeflection=0.0

ControlRate=0.1

AnimationID=10

 

So after correction it should look like this:

 

Setting[1].DeployValue=1.0

Setting[1].RetractValue=3.0

 

 

Retract value must be the higher.

 

 

And that's all! Those aircraft will now begin with open canopy and canopy will automatically close when aircraft takes speed. Same for wing folding, wings will only be folded when you are stopped. As soon as you take speed they unfold. heat.gif

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..