Jump to content
Fubar512

Frame rate tweak for Nvidia users

Recommended Posts

Those of you using an Nvidia graphics card to run SF2 should experience a nice little bump in average frame rate by implementing this tweak:

 

Open up your Nvidia control panel, and under 3D settings/manage 3D settings, scroll down to "Maximum Pre-rendered frames.  The default setting is 3.  Change it to 1, click OK to accept the change. and monitor your in-game framerate, specifically the average.  I gained a nice bump in FPS from this tweak, on the order of 15%.

 

Thanks to Brian Easy at Tech YES City.

 

  • Like 1

Share this post


Link to post
Share on other sites

seems like mine went up maybe 10-15 fps (considering I've never messed with any of my Nvidia setting before!!)

Share this post


Link to post
Share on other sites

The game seems to play much smoother with hardly any stuttering. This is especially true when on a CAS mission.  Used to get some stuttering when you turn on the camera for an EOGR,but with this setting there is no stuttering even if you leave the camera on.  Amazing, thanks.

Share this post


Link to post
Share on other sites

Cool - the "Game Loop"-stuttering over Hanoi is fully gone, and I haven't noticed ANY adverse effect (yet)! Many thanks!

 

Still need to see the effect in NA (as I am using Gerwin's Iceland Terrain, it already ran pretty smooth)...

 

What actually DOES this setting change?

Share this post


Link to post
Share on other sites

Cool - the "Game Loop"-stuttering over Hanoi is fully gone, and I haven't noticed ANY adverse effect (yet)! Many thanks!

 

Still need to see the effect in NA (as I am using Gerwin's Iceland Terrain, it already ran pretty smooth)...

 

What actually DOES this setting change?

 

The number of frames that are qued by the processor, before they are sent to the graphics card.

 

By limiting it to 1, you are probably avoiding a scenario where frames are literally "piling up" in the processor que, instead of being directly handed off to the graphics card, during intensive events (such as when flying over Hanoi amidst numerous AAA bursts and SAM launches).

  • Like 1

Share this post


Link to post
Share on other sites

Guys I'm having some problem. Now I'm using a 4 gig Nvidia graphics card. And it works Great. But when I use Fraps or Action! the screen goes Black. Any Ideas as to why this happen and how I can sort the problem?

Cheers

Share this post


Link to post
Share on other sites

Guys I'm having some problem. Now I'm using a 4 gig Nvidia graphics card. And it works Great. But when I use Fraps or Action! the screen goes Black. Any Ideas as to why this happen and how I can sort the problem?

Cheer

Why not use Nvidia Shadowplay instead?  I find it less resource-intensive than FRAPs, with at least the same (or even better) image quality.

  • Like 1

Share this post


Link to post
Share on other sites

Shadowplay is a great hint - but how do I get it to work in SF2? I thought I had switched it on by hitting Alt+F9 in game but nothing is recorded... Strange...

Showing the last x minutes does not show anything either... And - yes - I do have it switched on.... :beee:

Share this post


Link to post
Share on other sites

Hm, here on my rig Alt+F10 records the last so-and-so (predefined) minutes - Alt+F9 switches on/off the manual recording... Anyhow, neither does produce any video in the selected folder... I checked the commands in SF2 but nothing is assigned to the Alt+F9/F10-combination..... :baby:

 

In FS9 I do have a lot more of a problem as when hitting the Alt-key the tab-bar is opended and the Flighsimulator is put sitting idle.......

 

I AM right that when on the latest set of nvidia-drivers and with the "shadowplay" tab in the GeForce-Experience I do not have to download shadowplay individually again, am I?

Share this post


Link to post
Share on other sites

Okay, I found the solution: when playing I do so from my user account, but as I do have the game on the admin-level (and play "as admin"), I have to switch on shadopwplay in the admin-account as well... Simple as that... :baby:

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..